Bug 248009 - f-spot will not install because of missing dependency (mono(gtkhtml-sharp) = 2.16.0.0)
f-spot will not install because of missing dependency (mono(gtkhtml-sharp) = ...
Status: CLOSED DUPLICATE of bug 247831
Product: Fedora
Classification: Fedora
Component: gnome-sharp (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
: 248084 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-12 13:55 EDT by Scott Dowdle
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-14 10:01:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Dowdle 2007-07-12 13:55:54 EDT
Tried installing f-spot and it seems to have a dependency problem.  Here's the
output:

[root@dell Fedora]# yum install f-spot
Loading "installonlyn" plugin
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package f-spot.i386 0:0.3.5-2.fc7 set to be updated
--> Processing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 for package: f-spot
--> Finished Dependency Resolution
Error: Missing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 is needed by package
f-spot
[root@dell Fedora]#
Comment 1 George Billios 2007-07-13 01:32:37 EDT
Seems to happen after yesterdays update which includes an updated gnome-sharp
package (don't know if this is the problem).

Comment 2 George Billios 2007-07-13 10:06:41 EDT
It seems that gnome-sharp didn't include the libgtkhtml-sharp libs because
during build it searches for libgtkhtml-3.8.pc package to see if it will build
the libgtkhtml-sharp libs but gtkhtml3-devel package provides libgtkhtml-3.14.pc .

After I created a symbolic link libgtkhtml-3.8.pc pointing to libgtkhtml-3.14.pc
in the /usr/lib/pkgconfig directory and then did a gnome-sharp rebuilt and
installed it, now f-sport works fine! So better check the fedora build machine :)
Comment 3 Ricardo Jurczyk Pinheiro 2007-07-13 12:12:11 EDT
So, any changes into the Fedora main tree?
Comment 4 Brian Pepple 2007-07-14 09:52:27 EDT
*** Bug 248084 has been marked as a duplicate of this bug. ***
Comment 5 Brian Pepple 2007-07-14 10:00:01 EDT
This bug should have been opened against the gnome-sharp product.  since the
error isn't with f-spot.  after a quick search, a bug has already been opened
for gnome-sharp.  closing as a dup.
Comment 6 Brian Pepple 2007-07-14 10:01:02 EDT

*** This bug has been marked as a duplicate of 247831 ***

Note You need to log in before you can comment on or make changes to this bug.