Bug 248072 - XML validation errors when using DRAC fencing with Blades
Summary: XML validation errors when using DRAC fencing with Blades
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster   
(Show other bugs)
Version: 4
Hardware: All
OS: Linux
urgent
medium
Target Milestone: rc
Assignee: Ryan McCabe
QA Contact:
URL:
Whiteboard:
Keywords: ZStream
Depends On: 247731
Blocks: 503208
TreeView+ depends on / blocked
 
Reported: 2007-07-12 23:24 UTC by Norm Murray
Modified: 2018-10-27 14:44 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 19:35:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Wade Mealing 2007-07-12 23:24:57 UTC
+++ This bug was initially created as a clone of Bug #247731 +++


Description of problem:


Version-Release number of selected component (if applicable):
Running RHEL4U4 x86 with all errata applied.
System-config-cluster is version 1.0.27-1.0

After setting up cluster.conf to use DRAC fencing with a Dell Blade system the
system-config-cluster tool gives an XML validation error.



tmp/cluster.conf:8: element device: Relax-NG validity error : Invalid attribute
modulename for element device
Relax-NG validity error : Extra element fence in interleave
/tmp/cluster.conf:4: element clusternodes: Relax-NG validity error : Element
clusternode failed to validate content
/tmp/cluster.conf:5: element clusternode: Relax-NG validity error : Element
clusternodes has extra content: clusternode
/tmp/cluster.conf:6: element fence: Relax-NG validity error : Element
clusternode has extra content: fence
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Invalid sequence
in interleave
/tmp/cluster.conf:2: element cluster: Relax-NG validity error : Element cluster
failed to validate content
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf:8: element device: validity error : IDREF attribute name
references an unknown ID "drac-frame"
/tmp/cluster.conf fails to validate



How reproducible:
100%t



Steps to Reproduce:
This error occurs if you use the modulename option with DRAC fencing to specify
the module within a blade chassis.
See attached sample cluster.conf- created in system-config-cluster


The fix seems to be adding a modulename section to the FENCE schema.
Tested ok with my customer's configuration file.

 <group> 
  <attribute name="modulename"/>
 </group>

Comment 1 RHEL Product and Program Management 2007-07-12 23:34:04 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 2 Kiersten (Kerri) Anderson 2007-08-21 13:37:59 UTC
Am assuming this was supposed to be a cluster suite 4.x bug, changing version.

Comment 7 Lon Hohberger 2010-01-22 19:35:24 UTC
The provided cluster.conf validates with system-config-cluster-1.0.54-2.0

        <!-- DRAC -->
        <group>
         <optional>
          <attribute name="action"/>
         </optional>
         <optional>
          <attribute name="secure"/>
         </optional>
         <optional>
          <attribute name="modulename"/>
         </optional>
        </group>

Not sure why this was not closed.

http://rhn.redhat.com/errata/RHBA-2008-0792.html


Note You need to log in before you can comment on or make changes to this bug.