Bug 248096 - It does not seem to be possible to change flags in the Bug List view, for multiple bugs.
It does not seem to be possible to change flags in the Bug List view, for mul...
Status: CLOSED DUPLICATE of bug 231258
Product: Bugzilla
Classification: Community
Component: Query/Bug List (Show other bugs)
4.2
All Linux
high Severity medium (vote)
: ---
: ---
Assigned To: Simon Green
https://bugzilla.redhat.com/bugzilla/...
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-13 04:10 EDT by Jan Pazdziora
Modified: 2014-10-12 18:45 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-18 23:20:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Mozilla Foundation 281791 None None None Never

  None (edit)
Description Jan Pazdziora 2007-07-13 04:10:03 EDT
Description of problem:

I needed to set a sat-5.0.1 flag for multiple bugs. I got the bugs selected (see
the URL) but the Bug list page does not seem to provide any way to set a flag
for multiple bugs.

This is a severe regression in our process when we used "Blocks" to assign bugs
under tracker bugs.

Please add the possibility to change/set flags en masse se that we do not have
to do that by hand.

Version-Release number of selected component (if applicable):

2.18

How reproducible:

Any time I make a Bug List, there is nothing in the UI which would allow me to
change flags.

Steps to Reproduce:
1. Select multiple bugs.
2. Click "Change Several Bugs at Once" in the Bug List view, or "change several"
in the Dependency tree page.
3. In the resulting form, try to set flags.
  
Actual results:

Inputs to set flags are not shown.

Expected results:

I can add, delete, and modify flags.

Additional info:
Comment 1 David Lawrence 2007-08-08 16:27:58 EDT
We are researching a solution this feature request.
Comment 2 David Lawrence 2008-09-16 12:55:24 EDT
Red Hat Bugzilla is now using version 3.2 of the Bugzilla codebase and therefore this bug will need to be re-verified against the new release. With the updated code this bug may no longer be relevant or may have been fixed in the new code.
Updating bug version to 3.2.
Comment 3 Jan Pazdziora 2008-09-17 02:54:27 EDT
The bug is still relevant for bugzilla 3.2 -- there is nothing in the Web UI which would make it possible to set / change flags in the /buglist.cgi? ... &tweak=1 page.
Comment 4 David Lawrence 2008-09-17 10:43:17 EDT
This is a long standing upstream bug as well. We will look at this here as time allows but hopefully upstream will find a fix that will trickle down maybe.

https://bugzilla.mozilla.org/show_bug.cgi?id=281791

Dave
Comment 5 David Lawrence 2010-01-15 12:33:32 EST
Red Hat Bugzilla is now using version 3.4 of the Bugzilla codebase and
therefore this feature will need to be implemented against the new release.
Updating bug version to 3.2.
Comment 6 David Lawrence 2010-08-25 17:44:07 EDT
Red Hat has now upgraded to Bugzilla 3.6 and this bug will now be reassigned to that version. It would be helpful to the Bugzilla Development Team if this bug is verified to still be an issue with the latest version. If it is no longer an issue, then feel free to close, otherwise please comment that it is still a problem and we will try to address the issue as soon as we can.

Thanks
Bugzilla Development Team
Comment 7 Jan Pazdziora 2010-08-26 04:56:36 EDT
The issue is still present and the upstream bugzilla has no comment since

Max Kanat-Alexander    bugzilla-reviewers    2008-02-05 14:29:09 PST

Bugzilla 3.2 is now frozen. Only enhancements blocking 3.2 or specifically
approved for 3.2 may be checked in to the 3.2 branch. If you would like to
nominate your enhancement for Bugzilla 3.2, set "blocking3.2" tp "?", and
either the target milestone will be changed back, or the blocking3.2 flag will
be granted, if we will accept this enhancement for Bugzilla 3.2.

Dave, could you check if the upstream bugzilla is tracked / aligned reasonably well?
Comment 8 Jeff Fearn 2012-05-30 00:48:19 EDT
As part of the recent Bugzilla 2.4 upgrade the Bugzilla team are cleaning up bugs opened against old versions of Bugzilla. This bug has been flagged as an old bug and will be CLOSED WONTFIX in 7 days time.

If you believe this bug is an issue in the latest Bugzilla version please comment on this bug within 7 days. Doing so will ensure this bug is not closed automatically.

Thanks, the Bugzilla team.
Comment 9 Jan Pazdziora 2012-05-30 03:20:30 EDT
The bug is still relevant for bugzilla 4.2 -- there is nothing in the Web UI which would make it possible to set / change flags in the /buglist.cgi? ... &tweak=1 page. Bumping up version.
Comment 10 Simon Green 2012-06-18 23:20:57 EDT

*** This bug has been marked as a duplicate of bug 231258 ***

Note You need to log in before you can comment on or make changes to this bug.