Bug 248178 - smart gui crashes on 'edit' menu selection , everytime
Summary: smart gui crashes on 'edit' menu selection , everytime
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: smart   
(Show other bugs)
Version: 7
Hardware: x86_64 Linux
low
medium
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-13 18:21 UTC by Ian Fennell
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 09:04:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ian Fennell 2007-07-13 18:21:45 UTC
Description of problem: smart gui crashes on selection of edit menu


Version-Release number of selected component (if applicable):
0.50-45.fc7@x86_64

How reproducible:
everytime

Steps to Reproduce:
1.launch smart ,enter root password
2.click on edit menu
3.closes immediately , no warning bug buddy doesn't launch
  
Actual results:
program exits

Expected results:
access to 'edit' menu items

Additional info:run from terminal gives the following response:

[ian@localhost ~]$ smart-root --gui
/usr/lib64/python2.5/site-packages/smart/interfaces/gtk/interactive.py:369: 
GtkWarning: gdk_pixbuf_new_from_file: assertion `filename != NULL' failed
  gtk.main()
/usr/lib64/python2.5/site-packages/smart/interfaces/gtk/interactive.py:369: 
Warning: g_object_ref: assertion `G_IS_OBJECT (object)' failed
  gtk.main()
[ian@localhost ~]$


running debug kernel with many gtk and python debug packages, this is all i 
get

Comment 1 Ian Fennell 2007-07-17 01:21:15 UTC
gdb reports

Program exited with code 013.

Comment 2 Axel Thimm 2007-07-31 22:56:32 UTC
I can't reproduce it, but it looks more like a glib/gtk issue.


Note You need to log in before you can comment on or make changes to this bug.