Bug 24820 - sa1 and sa2 problems
sa1 and sa2 problems
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: sysstat (Show other bugs)
7.0
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
: 25590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 02:25 EST by josip
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 02:25:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description josip 2001-01-24 02:25:01 EST
The script /usr/lib/sa/sa1 gets started hourly only on Saturday and Sunday
(see /etc/crontab, also related to crontabs-1.8-1 package).  Meanwhile, the
script /usr/lib/sa/sa2 runs daily expecting to find daily files.  Since
weekday files are missing, spurious e-mail is sent to root.

Suggestions:
(1) /etc/crontab should start sa1 hourly every day, not just on weekends.
(2) /usr/lib/sa/sa2 should verify that the required log file exist:
    if [ -f ${DFILE} ]; then
       ${ENDIR}/sar $* -f ${DFILE} > ${RPT}
    fi
Comment 1 Preston Brown 2001-01-25 12:51:39 EST
fixed in errata going out today.
Comment 2 josip 2001-01-30 11:41:39 EST
The latest errata has a minor problem: it produces daily sar file at 4am,
summarizing only the previous 4 hours.  You may want to change the script
/usr/lib/sa/sa2 to summarize the previous day's data, e.g. by replacing the
'DATE=...' line with

DATE=`date --date=yesterday +%d`

This change will summarize yesterday's complete data (24hrs).
Comment 3 Preston Brown 2001-01-30 15:50:52 EST
good point.  Fixed in rawhide.
Comment 4 Preston Brown 2001-02-02 18:05:57 EST
*** Bug 25590 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.