Bug 248246 - Lack of /etc/rpm/macros.dist causes rpmbuild problems
Lack of /etc/rpm/macros.dist causes rpmbuild problems
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: fedora-release (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-14 01:24 EDT by Nigel Jones
Modified: 2013-01-09 20:40 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-14 06:20:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nigel Jones 2007-07-14 01:24:36 EDT
While I don't like to see fedora-release updated so late in the cycle, it'd be
nice if we could provide /etc/rpm/macros.dist like in F-7/Rawhide

I've struck an issue where by '%if 0%{?fedora} > 4 || 0%{?rhel} > 4' gets
evaluated as 'if 0 > 4 || 0 > 4' due to the lack of %{?fedora} been defined.

It'd be nice if a fix could be provided somehow.
Comment 1 Jesse Keating 2007-07-14 06:20:23 EDT
For FC6 you should be able to install the buildsys-macros package that comes
from the buildsys repo used by plague and mock.

http://buildsys.fedoraproject.org/buildgroups/6/<arch>/

Note You need to log in before you can comment on or make changes to this bug.