Bug 248249 - Problem with deskbar-applet and beagle-live
Summary: Problem with deskbar-applet and beagle-live
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: deskbar-applet   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Luke Macken
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-14 07:36 UTC by Jack Deslippe
Modified: 2016-09-20 02:37 UTC (History)
1 user (show)

Fixed In Version: 2.19.3-5.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-17 16:15:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 429107 None None None Never

Description Jack Deslippe 2007-07-14 07:36:11 UTC
Description of problem:
When you use the beagle-live plugin in deskbar-applet, do a search and click on
 a resulting file hoping to open it in the appropriate application, the file
does not open because an extra "file:/" tag has been applied to the name.  What
happens is a box appears proclaiming the file cannot be found.  

I found the following solution on an ubuntu bugzilla. 
https://bugs.launchpad.net/ubuntu/+source/deskbar-applet/+bug/93845

I have verified that the solution given works in fedora 7 as well.

The solution is to replace line 107 of the file
/usr/lib/deskbar-applet/handlers/beagle-live.py to:

  "action": lambda d: url_show(d["uri"]),

Comment 1 Jack Deslippe 2007-07-14 07:37:20 UTC
sorry the line to change is 106 not 107

Comment 2 Luke Macken 2007-07-15 17:59:03 UTC
I wrote a patch for deskbar-applet based on suggestions in
http://bugzilla.gnome.org/show_bug.cgi?id=429107#c7

This *should* be fixed in deskbar-applet-2.19.5-1.fc8.  There are a few
regressions in 2.19.5, so I think it's best to wait to push it to F7.

Comment 3 Fedora Update System 2007-07-23 15:43:54 UTC
deskbar-applet-2.19.3-5.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Jack Deslippe 2007-08-16 22:11:49 UTC
Yes, this is fixed in the updates-testing package.

Comment 5 Fedora Update System 2007-08-17 16:15:30 UTC
deskbar-applet-2.19.3-5.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.