Bug 248265 - Package fuse-emulator (and fuse-emulator-debuginfo) has unsatisfied (and wrong) dependencies
Package fuse-emulator (and fuse-emulator-debuginfo) has unsatisfied (and wron...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: fuse-emulator (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Ian Chapman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-14 14:51 EDT by Allan Engelhardt
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.8.0.1-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 13:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Allan Engelhardt 2007-07-14 14:51:01 EDT
Description of problem:

1. The dependencies for the package fuse-emulator-debuginfo.x86_64 0.8.0.1-1.fc7
and fuse-emulator.x86_64 0.8.0.1-1.fc7 can not be satisfied by yum
2. The X-debuginfo packages should not be dependent on X.

Version-Release number of selected component (if applicable):
fuse-emulator-debuginfo.x86_64 0.8.0.1-1.fc7
fuse-emulator.x86_64 0.8.0.1-1.fc7


How reproducible: Always


Steps to Reproduce:

The problem is the "dependency: perl(Fuse)" below (and the same for the
fuse-emulator.x86_64 package)

$ yum deplist fuse-emulator-debuginfo-*.fc7.x86_64
Loading "fastestmirror" plugin
Loading "kernel-module" plugin
Loading "installonlyn" plugin
Finding dependencies: 
Loading mirror speeds from cached hostfile
package: fuse-emulator-debuginfo.x86_64 0.8.0.1-1.fc7
  dependency: /usr/bin/perl
   provider: perl.i386 4:5.8.8-18.fc7
   provider: perl.x86_64 4:5.8.8-18.fc7
  dependency: perl(lib)
   provider: perl.i386 4:5.8.8-18.fc7
   provider: perl.x86_64 4:5.8.8-18.fc7
  dependency: perl(Fuse)
   Unsatisfied dependency
  dependency: perl(strict)
   provider: perl.i386 4:5.8.8-18.fc7
   provider: perl.x86_64 4:5.8.8-18.fc7

  
Actual results: 
1. Unsatisfiable dependencies 'perl(Fuse)' for both packages
2. Dependencies for the debuginfo package


Expected results:
1. No unsatisfiable dependencies for the fuse-emulator.x86_64 package
2. No dependencies at all for the fuse-emulator-debuginfo.x86_64 package

Additional info: Ruins my yum scripts :(
Comment 1 Ian Chapman 2007-07-15 09:02:23 EDT
Unfortunately I noticed this just after pushing the last build. Your comments
confuse me though. I'm not showing any unsatisfied dependencies for the
fuse-emulator package itself, only the debuginfo package which incorrectly has a
dependency on perl(Fuse), dragged in automatically by rpm as it's a locally used
perl module. 
Comment 2 Allan Engelhardt 2007-07-15 09:49:17 EDT
> I'm not showing any unsatisfied dependencies for the fuse-emulator package
itself ...

Correct.  I must have managed to confuse myself last night.  My apologies.

All we need is for fuse-emulator-debuginfo to drop all its dependencies.
Comment 3 Ian Chapman 2007-07-15 10:06:58 EDT
I've pushed a new update which should fix the problematic dependancies. The
debug package has:

/usr/bin/perl
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1

The perl dependency should be harmless
Comment 4 Fedora Update System 2007-07-16 13:00:09 EDT
fuse-emulator-0.8.0.1-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.