Bug 248283 - x86_64 save file corruption
x86_64 save file corruption
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rogue (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Wart
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-15 02:29 EDT by Wart
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 5.4.2-9.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 12:48:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wart 2007-07-15 02:29:07 EDT
Description of problem:
Reading a save file on x86_64 causes internal data corruption.  The problem is
in the state.c:rs_read_long() function which tries to read 4 bytes of data into
an uninitialized long pointer.

Instead, it should read the 4 bytes into an int and then cast to a long.

Version-Release number of selected component (if applicable):
rogue-5.4.2-8.fc7.x86_64


How reproducible:
Always

Steps to Reproduce:
1. Start a new game
2. kill one or two monsters
3. Save the game and exit
4. Start the game again from the save file (rogue -r)
5. Look at your experience points  

Actual results:
experience point counter is corrupted and displays an absurdly large value.

Expected results:
The same amount of experience is displayed as what was shown before the game was
saved.
Comment 1 Fedora Update System 2007-07-17 12:45:28 EDT
rogue-5.4.2-9.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 2 Fedora Update System 2007-07-19 12:48:17 EDT
rogue-5.4.2-9.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.