Bug 248289 - exim.conf refers to an undefined domainlist
exim.conf refers to an undefined domainlist
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: exim (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-15 05:12 EDT by Lauri Nurmi
Modified: 2013-04-12 15:14 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-12-02 07:15:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lauri Nurmi 2007-07-15 05:12:43 EDT
Description of problem:

The default exim.conf file has this line:
          domains = +local_domains : +relay_domains

That is the only reference to "relay_domains", which is undefined.  Probably it
is supposed to be "relay_to_domains", which is defined earlier.

Version-Release number of selected component (if applicable):
exim-4.63-3.el5

How reproducible:
Every time

Steps to Reproduce:
1. Install and start exim
2. Observe mails not being properly received due to errors like this:
2007-07-14 20:45:21 unknown named domain list "+relay_domains"
  
Actual results:


Expected results:


Additional info:
Tested on CentOS.
Comment 1 Felix Schwarz 2007-09-01 10:01:10 EDT
This bug was present in vanilla exim 4.63, too (look at src/configure.default)
and is solved in a later version (definitely in 4.68, don't know about earlier
versions).
Comment 7 errata-xmlrpc 2009-12-02 07:15:17 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1627.html

Note You need to log in before you can comment on or make changes to this bug.