Bug 248306 - The bind package "depends" on bind-chroot (by parent directory)
The bind package "depends" on bind-chroot (by parent directory)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bind (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Tkac
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-15 15:19 EDT by Robert Scheck
Modified: 2013-04-30 19:36 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-16 04:44:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-07-15 15:19:22 EDT
Description of problem:
Looks like you messed up the bind package a bit during the last build: bind 
package "depends" on bind-chroot when looking where the parent package is owned 
by. 

The bind package provides the files:
/var/named/chroot/etc/named.conf
/var/named/chroot/etc/named.rfc1912.zones
/var/named/chroot/var/named/named.ca
/var/named/chroot/var/named/named.empty
/var/named/chroot/var/named/named.localhost
/var/named/chroot/var/named/named.loopback

But the bind-chroot package provides the parent directories for the files:
/var/named/chroot/etc
/var/named/chroot/var
/var/named/chroot/var/named

So I MUST install bind-chroot package when I would like to have no orphaned 
directories. Please fix this wrong behaviour immediately, IMHO we're not at 
openSUSE, where I always must install the chroot package, aren't we? :)

Of course here on Fedora it's a soft-force, but don't do such dependency 
danglings, please.

Version-Release number of selected component (if applicable):
bind-9.5.0a5-2

How reproducible:
Everytime, see above.

Actual results:
bind package "depends" on bind-chroot

Expected results:
The bind-chroot package should be absolutely optional no strange parent/child 
dependencies like in this case.
Comment 1 Adam Tkac 2007-07-16 02:41:33 EDT
(In reply to comment #0)
> The bind package provides the files:
> /var/named/chroot/etc/named.conf
> /var/named/chroot/etc/named.rfc1912.zones
> /var/named/chroot/var/named/named.ca
> /var/named/chroot/var/named/named.empty
> /var/named/chroot/var/named/named.localhost
> /var/named/chroot/var/named/named.loopback

Yes, but please see into bind's spec. These files have %ghost directive. It's
due security purposes (someone could spoofing {chroot}/etc/named.conf before you
install chroot subpackage so this file have to be owned by bind)

> So I MUST install bind-chroot package when I would like to have no orphaned 
> directories. Please fix this wrong behaviour immediately, IMHO we're not at 
> openSUSE, where I always must install the chroot package, aren't we? :)

Yeah, definitely not :)

Please try install bind without chroot - all works as expected

Adam
Comment 2 Robert Scheck 2007-07-16 03:26:17 EDT
Again: The parent directory is owned by another package than the files the
bind package provides. Either please move the configuration files to the chroot 
package or do just vice versa.
Comment 3 Adam Tkac 2007-07-16 04:44:00 EDT
Looks like one of the pedantic changes for me but I've commited it. I will build
next release (9.5.0a6-3) when I fix bug #247856

Adam

Note You need to log in before you can comment on or make changes to this bug.