Bug 248309 - Fedora Eclipse and Fedora Java completely broken - beyond CRITICAL
Fedora Eclipse and Fedora Java completely broken - beyond CRITICAL
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
9
All Linux
low Severity high
: ---
: ---
Assigned To: Andrew Overholt
Fedora Extras Quality Assurance
:
Depends On: 314861
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-15 15:50 EDT by Kevin Crocker
Modified: 2008-06-04 15:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-06-04 15:53:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
eclipse crash bug report (28.63 KB, text/plain)
2007-09-16 16:15 EDT, Adam Goode
no flags Details
Error log when starting up eclipse (161.93 KB, text/plain)
2008-01-30 12:51 EST, Dan Thurman
no flags Details
bug file when runned with openjdk (227.15 KB, text/plain)
2008-05-18 09:22 EDT, Ivan Quirino
no flags Details
bug file when runned with gcj (1.02 KB, text/plain)
2008-05-18 09:25 EDT, Ivan Quirino
no flags Details

  None (edit)
Description Kevin Crocker 2007-07-15 15:50:06 EDT
Description of problem:
Eclipse (new install via yum after complete delete of previous Java and Eclipse)
refuses to start.

Version-Release number of selected component (if applicable):
Fedora Eclipse, Fedora Java

How reproducible:
100%

Steps to Reproduce:
1. Applications -> Programming -> Eclipse (click icon)
2.
3.
  
Actual results:
Alert box appears with useless information (content supplied below)

Expected results:
A working Eclipse

Additional info:

JVM terminated. Exit code=1
/usr/bin/java
-Xms40m
-Xmx256m
-Dosgi.sharedConfiguration.area=/usr/lib/eclipse/configuration
-jar startup.jar
-os linux
-ws gtk
-arch x86
-launcher /usr/bin/eclipse
-name Eclipse
-showsplash 600
-exitdata ca5801a
-vm /usr/bin/java
-vmargs
-Xms40m
-Xmx256m
-Dosgi.sharedConfiguration.area=/usr/lib/eclipse/configuration
-jar startup.jar 

What do I need to do to get Java and Eclipse working. I am getting EXTREMELY
frustrated with this. Installing Eclipse and Java should work.
Comment 1 Andrew Overholt 2007-07-16 11:23:44 EDT
Yes, it should work.  I obviously cannot reproduce your problem.  Can you see
what it says in ~/workspace/.metadata/.log?
Comment 2 Adam Goode 2007-09-16 15:26:26 EDT
I am getting this problem now. This is on rawhide, with either gij or icedtea.

.log is never touched. If it doesn't exist, it is not created. The failure
happens very quickly.

JVM terminated. Exit code=1
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/bin/java
-Xmx1G
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.0.v20070606/eclipse_1017a.so
-startup /usr/share/eclipse/startup.jar
-exitdata 26002a
-vm /usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/bin/java
-vmargs
-Xmx1G
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 
Comment 3 Adam Goode 2007-09-16 16:14:37 EDT
Now it is crashing. No idea what I did differently. Weird bugreport attached.
Comment 4 Adam Goode 2007-09-16 16:15:16 EDT
Created attachment 196781 [details]
eclipse crash bug report
Comment 5 Tim Lauridsen 2007-09-17 04:32:51 EDT
I get this one when starting eclipse as normal user.

JVM terminated. Exit code=1
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/bin/java
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar
-os linux
-ws gtk
-arch x86_64
-showsplash
-launcher /usr/lib64/eclipse/eclipse
-name Eclipse
--launcher.library
/usr/lib64/eclipse/plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.0.0.v20070606/eclipse_1017a.so
-startup /usr/share/eclipse/startup.jar
-exitdata 160017
-vm /usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0.x86_64/jre/bin/java
-vmargs
-Dosgi.sharedConfiguration.area=/usr/lib64/eclipse/configuration
-jar /usr/share/eclipse/startup.jar 

when i start eclipse as root it is working 
Comment 6 Andrew Overholt 2007-09-19 10:59:59 EDT
Tim:  Did you try temporarily moving ~/.eclipse out of the way?  How about
trying with gcj or another VM?

Adam:  please attach <your workspace>/.metadata/.log instead.  Thanks.
Comment 7 Adam Goode 2007-09-19 20:22:47 EDT
.log is never created. It crashes even before that point.
Comment 8 Adam Goode 2007-09-22 00:14:41 EDT
This is cute.

Java uses segv for heap resizing/GC.

Eclipse uses GTK.

GTK now loads libgnomebreakpad.so. (NEW!)

libgnomebreakpad catches segv and:

Thread 12 (Thread 1074792784 (LWP 32232)):
#0  0x00002aaaaacd50ff in __libc_waitpid (pid=32243, stat_loc=0x400fd850, options=0)
    at ../sysdeps/unix/sysv/linux/waitpid.c:41
#1  0x00002aaaf3ccd0f6 in g_spawn_sync () from /lib64/libglib-2.0.so.0
#2  0x00002aaaf3ccd3f8 in g_spawn_command_line_sync () from /lib64/libglib-2.0.so.0
#3  0x00002aaafe03a32d in bugbuddy_segv_handle (signum=<value optimized out>) at
gnome-breakpad.cc:208
#4  <signal handler called>
#5  0x00002aaaad1f6344 in ?? ()
#6  0x00002aaaddf5c4a8 in ?? ()
#7  0x0000000000000000 in ?? ()


"rpm -e bug-buddy" or "export GNOME_DISABLE_CRASH_DIALOG=1" is a workaround.
Comment 9 Jim Hayward 2007-09-22 07:29:42 EDT
Not sure if this is the same problem or related. Eclipse will start and run as
the normal user if I use gcj. For me the problem appears to only happen when
using IcedTea. When using IcedTea, Eclipse will run only as the root user.

eclipse-platform-3.3.0-20.fc8
java-1.7.0-icedtea-1.7.0.0-0.15.b19.snapshot.fc8
Comment 10 Adam Goode 2007-09-22 12:25:26 EDT
Yeah, I feel like I may have hijacked this bug inadvertently. Do you get the the
problem with all packages up to date, but bug-buddy not installed?
Comment 11 Tim Lauridsen 2007-09-26 09:36:35 EDT
I have tested it again
using 'eclipse --vm=/path/to/gcj/jvm' works.
So it is only fails when to running 'eclipse' with Icedtea (default) as normal user.
deleting '~./eclipse' dont help.
Comment 12 Michel Alexandre Salim 2007-09-28 22:09:14 EDT
I'm getting Adam Goode's problem here. If crash dialog is disabled, Eclipse
starts just fine. 
Comment 13 Andrew Overholt 2007-10-01 09:39:00 EDT
(In reply to comment #12)
> I'm getting Adam Goode's problem here. If crash dialog is disabled, Eclipse
> starts just fine. 

Could this be this bug-buddy issue:

http://bugzilla.gnome.org/show_bug.cgi?id=479929

?
Comment 14 Adam Goode 2007-10-01 14:03:00 EDT
Yes, that looks like the bug in Gnome. I think this patch is quite important for
F8, since this will trigger pretty much any SWT application when run with IcedTea.

Looking at the comments in the bug: I don't think it is the case that Java is
buggy, just that Java legitimately catches SIGSEGV for things like null pointer
detection, heap expansion, etc.

This comment: http://bugzilla.gnome.org/show_bug.cgi?id=479929#c15 doesn't
really see the whole picture of what is going on, for example.
Comment 15 Andrew Overholt 2007-10-01 15:13:58 EDT
Adam:  can you verify that that bug-buddy fix is in rawhide's bug-buddy?  If
not, can you file a bug against Fedora bug-buddy?  Thanks.
Comment 16 Jim Hayward 2007-10-04 08:16:57 EDT
With yesterdays updates Eclipse now runs for me as a normal user when using IcedTea.
Comment 17 Tim Lauridsen 2007-10-10 06:37:51 EDT
It works for me too on both i386 & x86_64.
Comment 18 Michel Alexandre Salim 2007-11-14 10:23:50 EST
This could probably be closed?
Comment 19 Dan Thurman 2008-01-30 12:51:51 EST
Created attachment 293458 [details]
Error log when starting up eclipse

It appears there is a problem with PDE but also appears the IDE is missing as
well as a plethora of other problems I do not understand.
Comment 20 Dan Thurman 2008-01-30 12:56:29 EST
No, I don't think this bug should be closed.

I do not have IcedTea installed at all. I get log errors everytime I try to 
start eclipse from Applications->Programming->Eclipse.

Please note, that fresh install of Eclipse during OS install from many weeks 
ago seemed to work. It became trashed on the latest updates as of a week or so 
ago.  This is for Fedora 8.

I have completely removed and resinstalled eclipse/java and the problem is 
reproducable every time I attempt to start eclipse.  Notice that I have had to 
manually remove eclipse files that was not being removed by the package 
manager found in /usr/lib/eclipse as well as /usr/share/eclipse.  I deleted 
~/.eclipse as well and it does not help. I get a error 
dialog telling me to review the log files found in ~/.eclipse

I provide the attachment for the latest log file as there are many logs 
created for each time I started eclipse, but basically they are the same 
errors.
Comment 21 Andrew Overholt 2008-01-30 13:00:58 EST
If you're not using IcedTea, what JVM are you using?

There haven't been any updates to Eclipse for Fedora 8 so I don't see how an
update broke your installation.  Judging from your mails on mailing lists,
you've done something as root using the Eclipse update manager that you should
not have done.  Again, send us the output of the commands listed here:

http://fedoraproject.org/wiki/DebuggingEclipseProblems

I'm willing to bet libswt3-gtk2 is messed up.  Either that or you used the
update manager as root to try to upgrade RPM-installed packages.  If you want
3.3.1.1, us an upstream download as the upgrade I proposed caused other issues.
Comment 22 Dan Thurman 2008-01-30 13:15:08 EST
I looked for jvm and it appears to be missing.  I cannot find where to install 
it as it appears it had somehow got removed.

I did a yum list jvm* and it is not found.

/etc/jvm is empty
/usr/share/jvm is empty

/usr/lib/jvm
java                    java-1.7.0-icedtea-1.7.0.0  jre-1.7.0
java-1.5.0              java-gcj                    jre-1.7.0-icedtea
java-1.5.0-gcj          java-icedtea                jre-gcj
java-1.5.0-gcj-1.5.0.0  jre                         jre-icedtea
java-1.7.0              jre-1.5.0
java-1.7.0-icedtea      jre-1.5.0-gcj

What do I need to do to ensure that jvm is properly installed?

Thanks!
Comment 23 Dan Thurman 2008-01-30 13:20:09 EST
uh, sorry - I did not read your entire message.  Here is what I found:

for f in `rpm -aq | egrep "eclipse|swt"`; do rpm -qV $f; done
===============================================================
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-atk-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-awt-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-cairo-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-glx-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-gnome-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-mozilla-gtk-3346.so
missing     /usr/lib/eclipse/configuration/org.eclipse.osgi/bundles/6/1/.cp/libswt-pi-gtk-3346.so
missing     /usr/lib/eclipse/libswt-atk-gtk-3346.so
missing     /usr/lib/eclipse/libswt-awt-gtk-3346.so
missing     /usr/lib/eclipse/libswt-cairo-gtk-3346.so
missing     /usr/lib/eclipse/libswt-glx-gtk-3346.so
missing     /usr/lib/eclipse/libswt-gnome-gtk-3346.so
missing     /usr/lib/eclipse/libswt-gtk-3346.so
missing     /usr/lib/eclipse/libswt-mozilla-gtk-3346.so
missing     /usr/lib/eclipse/libswt-pi-gtk-3346.so
missing     /usr/lib/eclipse/plugins/org.eclipse.swt.gtk.linux.x86_3.3.0.v3346.jar
missing     /usr/lib/eclipse/swt-gtk-3.3.0.jar
missing     /usr/lib/eclipse/swt-gtk-3.3.jar
missing     /usr/lib/eclipse/swt.jar
missing     /usr/share/eclipse/features/com.ibm.icu_3.6.1.v20070417
missing     /usr/share/eclipse/features/com.ibm.icu_3.6.1.v20070417/feature.xml
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/META-INF
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/META-INF/MANIFEST.MF
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/about.html
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/plugin.properties
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/plugin.xml
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/src
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/src/com.ibm.icu_3.6.1.v20070417
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/src/com.ibm.icu_3.6.1.v20070417/about.html
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/src/com.ibm.icu_3.6.1.v20070417/about_files
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/src/com.ibm.icu_3.6.1.v20070417/about_files/license.html
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/src/com.ibm.icu_3.6.1.v20070417/about_files/ucdterms.txt
missing     /usr/share/eclipse/plugins/com.ibm.icu.source_3.6.1.v20070417/src/com.ibm.icu_3.6.1.v20070417/src.zip
missing     /usr/share/eclipse/plugins/com.ibm.icu_3.6.1.v20070417.jar
missing     /usr/share/eclipse/plugins/org.eclipse.jdt.core_3.3.0.v_771.jar
missing     /usr/share/eclipse/plugins/org.apache.jasper_5.5.17.v200706111724.jar

which java
/usr/bin/java

readlink -f `which java`
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/jre/bin/java

which javac
/usr/bin/javac

readlink -f `which javac`
/usr/lib/jvm/java-1.7.0-icedtea-1.7.0.0/bin/javac

java -version
java version "1.7.0"
IcedTea Runtime Environment (build 1.7.0-b21)
IcedTea Server VM (build 1.7.0-b21, mixed mode)
Comment 24 Andrew Overholt 2008-01-30 13:29:12 EST
Okay, so you're running IcedTea which is good but you have some messed up RPMs.
 I really don't know how you got yourself into this mess, but you need to
re-install libswt3-gtk2, icu4j-eclipse, eclipse-ecj, and tomcat5-jasper-eclipse.
 If things *still* don't work after you've verified that rpm -qVa gives no
output, comment back here.
Comment 25 Andrew Overholt 2008-01-30 13:33:10 EST
BTW, Dan, if you get things working, it'd be awesome if you could write a wiki
FAQ or something explaining how to avoid the situation you got yourself into :)
 I can look it over to make sure it's all correct, too.  Also, once everything
is said and done, it would be nice if you could write something to fedora-list
and fedora-devel-java-list explaining how you fixed things and how to avoid
getting into a similar situation.
Comment 26 Dan Thurman 2008-01-30 16:47:44 EST
Sorry to take so long - it took awhile to go through it all.

To recap how I gotten into all of this mess was I used the Package Manager,
change the Tab to "List", and selected all eclipse* packages listed and clicked:
"Apply".

When I found that eclipse would not even start, I tried to back out completely
and start over.  That simply meant to go back into "Browse" tab, click
"Development", and uncheck "Eclipse" and click "Apply".

I noticed that in doing that, not all of the packages were actually removed, the
ones left behind were still appearing in the "List" tab and showing as "checked"
 next to some of the eclipse* packages.  So, I unchecked those, hit "Apply", and
those packages were removed.  However, looking unto /usr/lib/eclipse and
/usr/share/eclipse, there were still some files left there.  Since I could not
find any packages left un-installed, I simply deleted the eclipse directories
including that in ~/.eclipse.

At this point, its time to install the eclipse packages.  The hard part is,
which one?  I think I may have made the mistake of not only checking the
"Browse"->Development->Eclipse but also checking the eclipse-mylyn-trac that was
 appearing unchecked in the sub-category? Possibly.  I think in my confusion and
playing around with the "combination" of packages, I could not get eclipse to start.

So, I removed everything again, and then simply checked:
"Browse"->Development->Eclipse and left the sub-categories alone, eclipse is now
able to start!  Geez.

As for the rpm -qaV, there was a massive output - some files are missing and
sost reports after prelink dependency changes. Tons of stuff.  I will defer this
for another time.

I have a feeling that it was the other eclipse packages that caused me a lot of
grief.  So, I decided to see what eclipse packages were not installed.  The
following is a list I have taken from the PM->All:

eclipse-egit
eclipse-emf
eclipse-emf-examples
eclipse-emf-sdk
eclipse-emf-sdo
eclipse-emf-sdo-sdk
eclipse-emf-xsd
eclipse-emf-xsd-sdk
eclipse-gef
eclipse-gef-examples
eclipse-gef-sdk
eclipse-mylyn-pde
eclipse-mylyn-trac
eclipse-phpeclipse
eclipse-quickrex
eclipse-subclipse-book

At this point, I would have to ask you - should any of the not-installed
packages listed above be installed if at all, as root or as a normal user? I
could test each package to see if it causes eclipse to bomb out?

Finally, once I get past the Fedora package installs, I would like to ask if it
is safe to use Eclipse's own updater/installer to download packages from their
site and into the user's ~/.eclipse directory?  As I mentioned before, it seems
in doing so, eclipse's updater (by default) wants to install it in
/usr/{lib,share}/eclipse directory which will bomb out due to permissions?  I
haven't tested this out again, just yet, but will do so soon.

I would be glad to post this information to fedora-list and
fedora-devel-java-list once we finish this all up for any outstanding issues
that may crop up? I am not a Wiki user so that is out of my depth, sorry.

Thanks for your help!
Dan
Comment 27 Andrew Overholt 2008-01-30 17:26:10 EST
(In reply to comment #26)
> To recap how I gotten into all of this mess was I used the Package Manager,
> change the Tab to "List", and selected all eclipse* packages listed and clicked:
> "Apply".
> 
> When I found that eclipse would not even start

I'm sorry, but I highly doubt this is true.  How would a Developer Live CD work
if this were true?  I don't use the graphical package manager, but a "yum
install eclipse-sdk" or "yum install eclipse-platform" or "yum install
eclipse-cdt" or "yum install eclipse-pydev" should work just fine.  The
dependencies are all correct AFAIK so things are brought into the transaction
properly.

> However, looking unto /usr/lib/eclipse and
> /usr/share/eclipse, there were still some files left there.

Did you remove libswt3-gtk2 as well?  If not, that's why there were still files
there.  I think this is probably the root cause of all of your problems.  All
packages coming from an SRPM starting with the name "blah" don't have to be
called "blah"-<something> :)  If you removed all the eclipse-* RPMs and then
manually removed files in /usr/lib/eclipse, the re-installation of eclipse-*
wouldn't fix things, because libswt3-gtk2 would have been installed but broken
because you removed files.

> At this point, its time to install the eclipse packages.  The hard part is,
> which one?  I think I may have made the mistake of not only checking the
> "Browse"->Development->Eclipse but also checking the eclipse-mylyn-trac that was
>  appearing unchecked in the sub-category? Possibly.  I think in my confusion and
> playing around with the "combination" of packages, I could not get eclipse to
start.

Okay, well we obviously can't reproduce this so let's move on.
 
> So, I removed everything again, and then simply checked:
> "Browse"->Development->Eclipse and left the sub-categories alone, eclipse is now
> able to start!  Geez.

Okay, now we're getting somewhere.
 
> As for the rpm -qaV, there was a massive output - some files are missing and
> sost reports after prelink dependency changes. Tons of stuff.  I will defer this
> for another time.

Okay, well all I really cared about were the eclipse packages (see the command
here again:  http://fedoraproject.org/wiki/DebuggingEclipseProblems).  If you
have issues and have manually mucked with RPM-managed files, verify that they're
not missing files.

> I have a feeling that it was the other eclipse packages that caused me a lot of
> grief.

Well, I don't package them all so I can't say for sure, but I'm pretty sure they
should all work fine together :)

> eclipse-emf
> eclipse-emf-examples
> eclipse-emf-sdk
> eclipse-emf-sdo
> eclipse-emf-sdo-sdk
> eclipse-emf-xsd
> eclipse-emf-xsd-sdk

These packages shouldn't be in the repo anymore.  I guess I need to re-visit the
packagedb and ensure they're removed from the repo.  Regardless, they wouldn't
cause your issues.

> At this point, I would have to ask you - should any of the not-installed
> packages listed above be installed if at all, as root or as a normal user? I
> could test each package to see if it causes eclipse to bomb out?

First, to answer what I think you're asking:  no, none of them are crucial to
functioning of the framework.

You can't install RPMs system-wide as a normal user.  The packages you list are
all pieces of additional functionality.  Eclipse is made up of small bits of
functionality called plugins.  These are grouped together into what are called
features.  In Fedora, we try to match binary RPM 1-to-1 with features.  If you
don't want those bits of functionality, then don't install them :)

> Finally, once I get past the Fedora package installs, I would like to ask if it
> is safe to use Eclipse's own updater/installer to download packages from their
> site and into the user's ~/.eclipse directory?

Yes, the update manager will default to installing things into ~/.eclipse somewhere.

> As I mentioned before, it seems
> in doing so, eclipse's updater (by default) wants to install it in
> /usr/{lib,share}/eclipse directory which will bomb out due to permissions?  I
> haven't tested this out again, just yet, but will do so soon.

If it's defaulting to somewhere other than ~/.eclipse (and you're not running as
root - don't do that, BTW!), it's a bug and should be filed separately.

> I would be glad to post this information to fedora-list and
> fedora-devel-java-list once we finish this all up for any outstanding issues
> that may crop up? I am not a Wiki user so that is out of my depth, sorry.

It's okay, I'm now 99% convinced that the issues you're seeing are isolated to
your machine and were caused by things you did so let's not bother people other
than perhaps an "I've got things working now and it was as simple as installing
the RPMs" email when you're all straightened out :)

> Thanks for your help!

No problem.  I'm glad your setup is working now.
Comment 28 Bug Zapper 2008-05-13 23:04:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 29 Ivan Quirino 2008-05-18 09:22:47 EDT
Created attachment 305845 [details]
bug file when runned with openjdk
Comment 30 Ivan Quirino 2008-05-18 09:25:14 EDT
Created attachment 305846 [details]
bug file when runned with gcj
Comment 31 Ivan Quirino 2008-05-18 09:28:50 EDT
When running eclipse with gcj, it gives me this:

1c5d7cf0-522b-d102-20b59cf1-5318b842 is dumped

When running with openjdk, gives me this:

CompilerOracle: exclude
org/eclipse/core/internal/dtree/DataTreeNode.forwardDeltaWith
Endereço inválido
29f3d065-b3eb-f8c4-5ee1e9f4-5eee741a is dumped
Comment 32 Andrew Overholt 2008-06-04 15:53:38 EDT
Ivan:  please open a new bug against java-1.6.0-openjdk as your problems are
different than this bug (which I'm going to close).  Thanks.

Note You need to log in before you can comment on or make changes to this bug.