Bug 248327 - RHEL5: MegaRAID SATA RAID 150-4/6 are not supported 64-bit DMA
Summary: RHEL5: MegaRAID SATA RAID 150-4/6 are not supported 64-bit DMA
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Chip Coldwell
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-16 06:28 UTC by Vasily Averin
Modified: 2008-01-09 17:25 UTC (History)
3 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:55:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch against RHEL-5 kernel (674 bytes, text/x-patch)
2007-08-15 16:02 UTC, Chip Coldwell
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Vasily Averin 2007-07-16 06:28:27 UTC
Description of problem:
smp and hugemem kernels hangs or tried to access beyond end of device on the
nodes with more than 4Gb memory and LSI Logic MegaRAID SATA RAID Controllers
(150-4 or 150-6).

I've reported about this issue in RHEL4:
LSI Logic MegaRAID SATA RAID Controllers (150-4 and 150-6) are not works
correctly if more than 4 GB memory installed on the node. According to Ju
Seokmann this hardware is not supported 64 bit DMA.
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=210852

However this issue is still not fixed in RHEL5 kernels, the following patch has
been lost:
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=8741ca71a3f626a56595b88200ebf952ce77ceef

Comment 2 Chip Coldwell 2007-08-15 16:02:51 UTC
Created attachment 161375 [details]
patch against RHEL-5 kernel

Comment 3 Don Zickus 2007-08-21 18:37:10 UTC
in 2.6.18-42.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 6 errata-xmlrpc 2007-11-07 19:55:58 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.