Bug 248343 - ktron should be renamed because it violates the tron trademark
ktron should be renamed because it violates the tron trademark
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdegames (Show other bugs)
rawhide
All Linux
high Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-16 06:07 EDT by Hans de Goede
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 16:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to remove Tron and Sokoban trademarks (55.79 KB, patch)
2007-08-04 18:20 EDT, Kevin Kofler
no flags Details | Diff
KFileReplace script to remove Tron and Sokoban trademarks (1.20 KB, text/plain)
2007-08-04 18:20 EDT, Kevin Kofler
no flags Details
Patch to remove Tron and Sokoban trademarks (rev2) (59.54 KB, patch)
2007-08-08 01:35 EDT, Kevin Kofler
no flags Details | Diff

  None (edit)
Description Hans de Goede 2007-07-16 06:07:09 EDT
The name ktron is way to similar to the name Tron, and thus a trademark
violation. This can be easily resolved by renaming ktron (and removing the usage
of the word tron from docs and in game texts).

This being a problem has been acked by Spot, see:
https://www.redhat.com/archives/fedora-games-list/2007-July/msg00002.html
Comment 1 Kevin Kofler 2007-08-04 00:30:34 EDT
This game is not in KDE 4, so this means this will have to be reassigned to 
kdegames3 when KDE 4 gets imported.

Other games in kdegames3 which could possibly use similar treatment: KSokoban, 
KSmiletris (as Gnometris was found to be a problem because of the "tris"), 
KAsteroids (pretty generic in principle, but still the original was 
named "Asteroids" so it may be a problem).

I wonder if the trademark issues are part of the reason nobody volunteered to 
maintain these upstream.
Comment 2 Kevin Kofler 2007-08-04 00:45:10 EDT
The patch shouldn't be hard to do thanks to KFileReplace, but the real question 
is what to rename them to. Here's my ideas:
* KAsteroids -> ? I thought of KPlanetoids, but there's already a freeware game 
called Planetoids which isn't an Asteroids game at all [1].
* KSmiletris -> KSmiles or KFallingSmiles
* KSokoban -> KBoxPush
* KTron -> KSnakeDuel

[1] 
http://linux.softpedia.com/get/GAMES-ENTERTAINMENT/Arcade/Planetoids-9571.shtml
Comment 3 Kevin Kofler 2007-08-04 18:20:19 EDT
Created attachment 160701 [details]
Patch to remove Tron and Sokoban trademarks

The attached patch removes the Tron and Sokoban trademarks from kdegames 3.
KTron is renamed to KSnakeDuel, KSokoban to KBoxPush. I also tracked down the
original author of the levels which are currently shipped with KSokoban,
checked that the licensing is acceptable for Fedora content (it's
"Distributable, no modification allowed") and fixed AUTHORS to credit the
levels properly:

The included level sets (Sasquatch, Mas Sasquatch, Sasquatch III,
Sasquatch IV and Microban) are the work of:
David W. Skinner <sasquatch@bentonrea.com>
http://users.bentonrea.com/~sasquatch/sokoban/
From the web page:
> These sets may be freely distributed provided they remain unchanged
> and credited with my name and email address.

I ran the KFileReplace script I'm going to attach, then hand-edited AUTHORS as
above. I also hand-edited ksokoban/index.docbook with 2 minor edits so the
introductory paragraph about the original game makes sense. With this change,
this bug should be resolved and it should no longer be necessary to delete
KSokoban for RHEL either.
Comment 4 Kevin Kofler 2007-08-04 18:20:53 EDT
Created attachment 160702 [details]
KFileReplace script to remove Tron and Sokoban trademarks
Comment 5 Kevin Kofler 2007-08-08 01:35:37 EDT
Created attachment 160878 [details]
Patch to remove Tron and Sokoban trademarks (rev2)

This version of the patch has some additional user-visible instances of
"sokoban" and "tron" removed. There should be really no user-visible instances
left within kdegames now. I have applied the patch to my kdegames3 package,
verified that it still builds and that the games and menus don't show the
trademarks. So the patch is ready to go for F6/F7/devel updates.

I have some bad news however: there are translated versions of the manuals with
the offending trademarks in kde-i18n. Work never ends. :-(
Comment 6 Kevin Kofler 2007-09-13 01:21:02 EDT
Can we please get this patch applied?
Comment 7 Ngo Than 2007-09-20 16:42:23 EDT
it's commited in fc6/f7/devel CVS. I will push new package with the fix for 
fc6/f7 this week. Thanks Kevin Kofler for great work.

Note You need to log in before you can comment on or make changes to this bug.