Bug 248382 - Regression in support for third party drivers in RHEL5 kernels post -23.
Summary: Regression in support for third party drivers in RHEL5 kernels post -23.
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Jeff Garzik
QA Contact:
URL:
Whiteboard:
Keywords:
: 248803 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-16 15:35 UTC by Jon Masters
Modified: 2007-11-30 22:07 UTC (History)
5 users (show)

Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 19:56:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0959 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5 Update 1 2007-11-08 00:47:37 UTC

Description Jon Masters 2007-07-16 15:35:50 UTC
Description of problem:

A recent patch to the RHEL5.1 public beta kernel has caused a regression in
behavior of the ipw3945-kmod package. This driver now causes an immediate kernel
oops on load, which triggers a kernel panic.

Version-Release number of selected component (if applicable):

All releases.

How reproducible:

Load driver on recent RHEL5.1 kernel (-34).

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 John W. Linville 2007-07-19 16:54:10 UTC
*** Bug 248803 has been marked as a duplicate of this bug. ***

Comment 2 Tim Burke 2007-07-19 20:41:21 UTC
Changing package to kernel -as it has been identified thats where the issue is
(not the separate ipw3945-kmod.

Comment 4 Jay Turner 2007-07-23 13:10:16 UTC
Not sure why this hasn't going into modified, as a fix was made available in the
2.6.18-36.el5 kernel (maybe additional work is coming down the pipe??)  Anyway,
I'm able to run the 2.6.18-36.el5 kernel alongside kmod-ipw3945-1.0-4.7.el5
without any problems (previously I was seeing kernel panics on boot with the
ipw3945 kmod and the "busted" kernels.)

Comment 8 Don Zickus 2007-07-23 16:17:53 UTC
in 2.6.18-36.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 11 errata-xmlrpc 2007-11-07 19:56:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html



Note You need to log in before you can comment on or make changes to this bug.