Bug 248501 - [Bug] Ifup fails on a dhcp configuration with two nics
[Bug] Ifup fails on a dhcp configuration with two nics
Status: CLOSED DUPLICATE of bug 248502
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts (Show other bugs)
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: initscripts Maintenance Team
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2007-07-17 02:01 EDT by Narendra K
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-07-17 02:12:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Narendra K 2007-07-17 02:01:38 EDT
Description of problem: On a system with two onboard nics ifup on the second 
nic fails with both nics configured to get the DHCP ip. Ifup on the first nic 
gets the ip for the second nic also. 

Version-Release number of selected component (if applicable):
RHEL 5 - Kernel version : 2.6.18-8.el5
initscripts - 8.45.14.EL-1

How reproducible: Always

Steps to Reproduce:
1. Install RHEL5 on a system with two onboard BCM 5708 Gigabit Ethernet nics 
2. Configure the nics to get the ip from a DHCP server
3. Start the network with service network restart
4. Execute the following steps :
        Ifdown eth0
        Ifdown eth1
        rmmod bnx2 
5. Now issue ifup eth0. It succeeds. Intermittently it fails also.
6. Issue ifup eth1 - It fails.
Actual results:

Step 5 gets ip address for both and eth0 and eth1 irrespective of whether ifup 
eth0 succeeded or failed. Ifup on eth1 fails with messages like 
Determining IP information for eth1...failed. 
Determining IP information for eth1...dhclient(14063) is already unning exiting

Expected results:
Ifup on eth0 should get ip address for only eth0 and ifup on eth1 should not 

Additional info:
1. With the nics configured to get static ips the ifup on the eth0 and  eth1 
doesn't fail.But ifup on eth0 gets the ip for both the nics. 
2. The same behaviour is also observed in intel cards also. 
3. The same behaviour is observed if one nic is onboard and one is addon.
Comment 1 Narendra K 2007-07-17 02:12:45 EDT

*** This bug has been marked as a duplicate of 248502 ***

Note You need to log in before you can comment on or make changes to this bug.