Bug 248502 - [Bug] Ifup fails on a dhcp configuration with two nics
Summary: [Bug] Ifup fails on a dhcp configuration with two nics
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: initscripts   
(Show other bugs)
Version: 5.0
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: initscripts Maintenance Team
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 248501 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-17 06:03 UTC by Narendra K
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-18 19:00:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages when configured with dhcp (2.78 KB, text/plain)
2007-07-17 06:03 UTC, Narendra K
no flags Details
/var/log/messages/ when nics confiured to get static ip (1.62 KB, text/plain)
2007-07-17 06:07 UTC, Narendra K
no flags Details
ifconfig output after ifup on the first nic (1.44 KB, text/plain)
2007-07-17 06:08 UTC, Narendra K
no flags Details
ps ax | grep dhclient output after ifup on the first nic (290 bytes, text/plain)
2007-07-17 06:09 UTC, Narendra K
no flags Details
Configuration for eth0 (138 bytes, text/plain)
2007-07-18 06:15 UTC, Narendra K
no flags Details
Configuration for eth1 (138 bytes, text/plain)
2007-07-18 06:16 UTC, Narendra K
no flags Details

Description Narendra K 2007-07-17 06:03:17 UTC
Description of problem: On a system with two onboard nics ifup on the second 
nic fails with both nics configured to get the DHCP ip. Ifup on the first nic 
gets the ip for the second nic also. 

Version-Release number of selected component (if applicable):
RHEL 5 - Kernel version : 2.6.18-8.el5
initscripts - 8.45.14.EL-1

How reproducible: Always

Steps to Reproduce:
1. Install RHEL5 on a system with two onboard BCM 5708 Gigabit Ethernet nics 
2. Configure the nics to get the ip from a DHCP server
3. Start the network with service network restart
4. Execute the following steps :
        Ifdown eth0
        Ifdown eth1
        rmmod bnx2 
5. Now issue ifup eth0. It succeeds. Intermittently it fails also.
6. Issue ifup eth1 - It fails.
 
Actual results:

Step 5 gets ip address for both and eth0 and eth1 irrespective of whether ifup 
eth0 succeeded or failed. Ifup on eth1 fails with messages like 
Determining IP information for eth1...failed. 
Determining IP information for eth1...dhclient(14063) is already unning exiting
exiting.
failed.

Expected results:
Ifup on eth0 should get ip address for only eth0 and ifup on eth1 should not 
fail.

Additional info:
1. With the nics configured to get static ips the ifup on the eth0 and  eth1 
doesn't fail.But ifup on eth0 gets the ip for both the nics. 
2. The same behaviour is also observed in intel cards also. 
3. The same behaviour is observed if one nic is onboard and one is addon.

Comment 1 Narendra K 2007-07-17 06:03:17 UTC
Created attachment 159400 [details]
/var/log/messages when configured with dhcp

Comment 2 Narendra K 2007-07-17 06:07:09 UTC
Created attachment 159402 [details]
/var/log/messages/ when nics confiured to get static ip

Comment 3 Narendra K 2007-07-17 06:08:35 UTC
Created attachment 159403 [details]
ifconfig output after ifup on the first nic

Comment 4 Narendra K 2007-07-17 06:09:42 UTC
Created attachment 159405 [details]
ps ax | grep dhclient output after ifup on the first nic

Comment 5 Narendra K 2007-07-17 06:12:48 UTC
*** Bug 248501 has been marked as a duplicate of this bug. ***

Comment 6 Bill Nottingham 2007-07-17 14:56:34 UTC
Please attach your config files.

Comment 7 Narendra K 2007-07-18 06:15:17 UTC
Created attachment 159498 [details]
Configuration for eth0

Comment 8 Narendra K 2007-07-18 06:16:14 UTC
Created attachment 159499 [details]
Configuration for eth1

Comment 9 Narendra K 2007-07-18 09:35:46 UTC
I have attached the configuration files in comment #7 and comment #8.

Comment 10 Bill Nottingham 2007-07-18 19:00:50 UTC
With your configuration, it is *expected* that on module load/interface creation
that ifup will be run; if you don't want that, set 'HOTPLUG=no'. 


Note You need to log in before you can comment on or make changes to this bug.