Bug 248507 - Cannot access to several pages
Cannot access to several pages
Status: CLOSED NOTABUG
Product: Fedora Localization
Classification: Fedora
Component: Website (Show other bugs)
unspecified
All Linux
low Severity low
: ---
: ---
Assigned To: Dimitris Glezos
Diego Búrigo Zacarão
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-17 03:12 EDT by Alain Portal
Modified: 2007-07-30 10:44 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 10:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alain Portal 2007-07-17 03:12:38 EDT
When I try to access to http://translate.fedoraproject.org/releases/,
I get the following error:

<!-- The above is a description of an error in a Python program, formatted
     for a Web browser because the 'cgitb' module was enabled.  In case you
     are not reading this in a Web browser, here is the original traceback:

Traceback (most recent call last):
  File "/srv/web/translation/releases.py", line 510, in ?
    t = Releases(deep=0)
  File "/srv/web/translation/releases.py", line 218, in __init__
    myModules = modules.XmlModules(defaults.modules_xml)
  File "/srv/web/translation/modules.py", line 9, in __init__
    self.modules = data.getModules( only = module)
  File "/srv/web/translation/data.py", line 10, in getModules
    return readFromFile(defaults.modules_xml, only)
  File "/srv/web/translation/data.py", line 50, in readFromFile
    dom = libxml2.parseFile (filename)
  File "/usr/lib64/python2.4/site-packages/libxml2.py", line 1240, in 
parseFile
    if ret is None:raise parserError('xmlParseFile() failed')
parserError: xmlParseFile() failed

-->

When I try to access to http://translate.fedoraproject.org/module/,
I get the following error:

<!-- The above is a description of an error in a Python program, formatted
     for a Web browser because the 'cgitb' module was enabled.  In case you
     are not reading this in a Web browser, here is the original traceback:

Traceback (most recent call last):
  File "/srv/web/translation/view-module.py", line 208, in ?
    go_go()
  File "/srv/web/translation/view-module.py", line 151, in go_go
    allmodules = modules.XmlModules()
  File "/srv/web/translation/modules.py", line 9, in __init__
    self.modules = data.getModules( only = module)
  File "/srv/web/translation/data.py", line 10, in getModules
    return readFromFile(defaults.modules_xml, only)
  File "/srv/web/translation/data.py", line 50, in readFromFile
    dom = libxml2.parseFile (filename)
  File "/usr/lib64/python2.4/site-packages/libxml2.py", line 1240, in 
parseFile
    if ret is None:raise parserError('xmlParseFile() failed')
parserError: xmlParseFile() failed

-->


If I try to view a language page in 
http://translate.fedoraproject.org/languages/, I get a blank page.


If I try to view a team page in http://translate.fedoraproject.org/teams/, I 
get a blank page.
Comment 1 Alain Portal 2007-07-18 08:33:02 EDT
Can somebody confirm this bug?
I should want to be sure it isn't french specific.
Comment 2 Alain Portal 2007-07-18 09:10:04 EDT
It seems to be french specific :-(
Comment 3 Diego Búrigo Zacarão 2007-07-18 09:15:51 EDT
All links you said above are working properly to me in pt_BR.
I can see those pages without problems.

Maybe that problem can be related with your language (fr.po).
Are you sure that your PO file is fully encoded in UTF-8?

Do you have problems to access the follow links too?
http://translate.fedoraproject.org/module/anaconda
http://translate.fedoraproject.org/languages/pt_BR

If you change your environment language, for example to pt_BR, what it happens?
Comment 4 Alain Portal 2007-07-18 09:19:12 EDT
(In reply to comment #3)
> All links you said above are working properly to me in pt_BR.
> I can see those pages without problems.
> 
> Maybe that problem can be related with your language (fr.po).
> Are you sure that your PO file is fully encoded in UTF-8?

Yes

> Do you have problems to access the follow links too?
> http://translate.fedoraproject.org/module/anaconda
> http://translate.fedoraproject.org/languages/pt_BR
> 
> If you change your environment language, for example to pt_BR, what it 
happens?

All work fine :-(
I can access pages that I couldn't access in "french"
Comment 5 Diego Búrigo Zacarão 2007-07-20 10:55:19 EDT
The problem was related with &nbsp; 
Just removing all &nbsp; entries of fr.po the web site got works fine.

Note You need to log in before you can comment on or make changes to this bug.