Bug 24863 - initscripts-5.55-1 network error!
Summary: initscripts-5.55-1 network error!
Status: CLOSED DUPLICATE of bug 24674
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-24 16:41 UTC by Sammy
Modified: 2014-03-17 02:18 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 16:42:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2001-01-24 16:41:58 UTC
I just installed this and my network did not come up on reboot.
Examining the /etc/rc.d/init.d/network script (and error messages
on the console) the lines:

            egrep -v '(~|\.bak)$' \
            egrep -v 'ifcfg-ippp[0-9]+$' | \
            egrep 'ifcfg-[a-z0-9]+$' | \ 

give an error and kill the script. Removing them fixes everything.
My /etc/syscconfig/network-scripts directory has the contents:

ifcfg-eth0  ifdown-post*  ifup@          ifup-plip*  ifup-routes*
ifcfg-lo*   ifdown-ppp*   ifup-aliases*  ifup-post*  ifup-sl*
ifdown@     ifdown-sl*    ifup-ipx*      ifup-ppp*  
network-functions          

and  ifcfg-eth0 has:

DEVICE=eth0
BOOTPROTO=static
IPADDR=129.59.116.57
NETMASK=255.255.254.0
ONBOOT=yes
BROADCAST=129.59.117.255
NETWORK=129.59.116.0
USERCTL=no

Comment 1 Bill Nottingham 2001-01-24 16:51:24 UTC

*** This bug has been marked as a duplicate of 24674 ***


Note You need to log in before you can comment on or make changes to this bug.