This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 248682 - skip-broken plugin ignores dependancies
skip-broken plugin ignores dependancies
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 04:11 EDT by Pavel Rosenboim
Modified: 2008-03-12 12:13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-12 12:13:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pavel Rosenboim 2007-07-18 04:11:29 EDT
Description of problem:
Running 'yum --skip-broken update' causes yum to install broken packages instead
of ignoring them. Currently, a gnome-sharp package breaks f-spot, but running
command 'yum --skip-broken update' will install it anyway.


Version-Release number of selected component (if applicable):
yum-utils-1.1.5-1.fc7

How reproducible:
Always.

Steps to Reproduce:
1. Run yum --skip-broken update when there are unresolvable dependencies
  
Actual results:
Yum installs packages with broken dependencies

Expected results:
Skip such packages

Additional info:
Running 'yum update':
[root@pashar pasha]# yum update
Loading "installonlyn" plugin
Loading "priorities" plugin
Loading "kernel-module" plugin
Loading "fastestmirror" plugin
Loading "security" plugin
Loading "skip-broken" plugin
Loading "changelog" plugin
Loading "allowdowngrade" plugin
Loading "fedorakmod" plugin
Loading "downloadonly" plugin
Loading "protectbase" plugin
Setting up Update Process
Loading mirror speeds from cached hostfile
livna                     100% |=========================| 2.1 kB    00:00     
fedora                    100% |=========================| 2.1 kB    00:00     
updates                   100% |=========================| 1.9 kB    00:00     
freshrpms                 100% |=========================| 2.1 kB    00:00     
71 packages excluded due to repository priority protections
Skipping security plugin, no data
0 packages excluded due to repository protections
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package gnome-sharp.i386 0:2.16.0-2.fc7 set to be updated
--> Processing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 for package: f-spot
--> Finished Dependency Resolution
Error: Missing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 is needed by package
f-spot

Running yum --skip-broken update
Loading "installonlyn" plugin
Loading "priorities" plugin
Loading "kernel-module" plugin
Loading "fastestmirror" plugin
Loading "security" plugin
Loading "skip-broken" plugin
Loading "changelog" plugin
Loading "allowdowngrade" plugin
Loading "fedorakmod" plugin
Loading "downloadonly" plugin
Loading "protectbase" plugin
Setting up Update Process
Loading mirror speeds from cached hostfile
71 packages excluded due to repository priority protections
Skipping security plugin, no data
0 packages excluded due to repository protections
Resolving Dependencies
Skipping security plugin, no data
**** Checking packages for dependency problems
**** Checking for dep problems  : gnome-sharp - 2.16.0-2.fc7.i386 
--> Running transaction check
---> Package gnome-sharp.i386 0:2.16.0-2.fc7 set to be updated
****   OK : gnome-sharp.i386 0-2.16.0-2.fc7 - u
**** Checking for dep problems  : gnome-sharp - 2.16.0-1.fc6.i386 
--> Running transaction check
--> Processing Dependency: mono(gtkhtml-sharp) = 2.16.0.0 for package: f-spot
--> Processing Dependency: gnome-sharp for package: monodevelop
--> Finished Dependency Resolution
****   Failed 
****     Unresolveable requirement mono(gtkhtml-sharp) = 2.16.0.0 for f-spot 
****     Unresolveable requirement gnome-sharp for monodevelop 
**** Packages with dependency resolving errors 
**** gnome-sharp - 2.16.0-1.fc6.i386 
****   2 
****   2 
**** End Checking packages for dependency problems
--> Running transaction check
---> Package gnome-sharp.i386 0:2.16.0-2.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 gnome-sharp             i386       2.16.0-2.fc7     updates           412 k

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 412 k
Is this ok [y/N]:

Answering yes causes yum to actually install gnome-sharp.
Comment 1 Pavel Rosenboim 2007-07-19 02:49:51 EDT
gnome-sharp package was updated again to 2.16.0-2.fc7, and the new one does not
break f-spot, so the problem is not reproducible anymore with this package.
Probably, it will be easy to reproduce with rawhide where broken dependencies
are introduced often.
Comment 2 Florian Festi 2007-07-19 06:23:15 EDT
I'd guess that this bug is another side effect of a outdated cache in yum-3.2.
It is also responsible for bug #242368 (and bug #246625). You can try if the
patch attached there fixes the problem.
Comment 3 Pavel Rosenboim 2007-07-19 09:13:18 EDT
Only partially. I applied a patch to a file
/usr/lib/python2.5/site-packages/yum/depsolve.py

Now (with current broken updates):
yum --skip-broken update:
Loading "installonlyn" plugin
Loading "priorities" plugin
Loading "kernel-module" plugin
Loading "fastestmirror" plugin
Loading "security" plugin
Loading "skip-broken" plugin
Loading "changelog" plugin
Loading "allowdowngrade" plugin
Loading "fedorakmod" plugin
Loading "downloadonly" plugin
Loading "protectbase" plugin
Setting up Update Process
Loading mirror speeds from cached hostfile
71 packages excluded due to repository priority protections
Skipping security plugin, no data
0 packages excluded due to repository protections
Resolving Dependencies
Skipping security plugin, no data
**** Checking packages for dependency problems
**** Checking for dep problems  : liferea - 1.2.19-3.fc7.i386 
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: liferea
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 2.0.0.4 for package: liferea
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: firefox = 2.0.0.4-2.fc7 for package: firefox-devel
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Finished Dependency Resolution
****   Failed 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package blam 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package Democracy 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for galeon 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package
gnome-python2-gtkmozembed 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for yelp 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for devhelp 
**** Checking for dep problems  : firefox-devel - 2.0.0.5-1.fc7.i386 
--> Running transaction check
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.5-1.fc7 for package: firefox-devel
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 2.0.0.4 for package: liferea
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: firefox = 2.0.0.4-2.fc7 for package: firefox-devel
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Finished Dependency Resolution
****   Failed 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package blam 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package Democracy 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for galeon 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package
gnome-python2-gtkmozembed 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for yelp 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for devhelp 
**** Checking for dep problems  : liferea - 1.2.19-2.fc7.i386 
--> Running transaction check
****   OK : liferea.i386 0-1.2.19-2.fc7 - None
**** Checking for dep problems  : galeon - 2.0.3-9.fc7.i386 
--> Running transaction check
****   OK : galeon.i386 0-2.0.3-9.fc7 - None
**** Checking for dep problems  : devhelp - 0.13-9.fc7.i386 
--> Running transaction check
---> Package devhelp.i386 0:0.13-9.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: devhelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package devhelp.i386 0:0.13-9.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 2.0.0.4 for package: liferea
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: firefox = 2.0.0.4-2.fc7 for package: firefox-devel
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Finished Dependency Resolution
****   Failed 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package blam 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package Democracy 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for galeon 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package
gnome-python2-gtkmozembed 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for yelp 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for devhelp 
**** Checking for dep problems  : epiphany - 2.18.3-2.fc7.i386 
--> Running transaction check
---> Package epiphany.i386 0:2.18.3-2.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: epiphany
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package epiphany.i386 0:2.18.3-2.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 2.0.0.4 for package: liferea
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: firefox = 2.0.0.4-2.fc7 for package: firefox-devel
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Finished Dependency Resolution
****   Failed 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package blam 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package Democracy 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for galeon 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package
gnome-python2-gtkmozembed 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for yelp 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for devhelp 
**** Checking for dep problems  : yelp - 2.18.1-5.fc7.i386 
--> Running transaction check
---> Package yelp.i386 0:2.18.1-5.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: yelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package yelp.i386 0:2.18.1-5.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 2.0.0.4 for package: liferea
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: firefox = 2.0.0.4-2.fc7 for package: firefox-devel
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package galeon.i386 0:2.0.3-10.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Finished Dependency Resolution
****   Failed 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package blam 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package Democracy 
****     Missing Dependency: gecko-libs = 1.8.1.4 is needed by package
epiphany-extensions 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package
gnome-python2-gtkmozembed 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for yelp 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for devhelp 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions 
**** Checking for dep problems  : firefox-devel - 2.0.0.4-2.fc7.i386 
--> Running transaction check
****   OK : firefox-devel.i386 0-2.0.0.4-2.fc7 - None
**** Checking for dep problems  : epiphany - 2.18.3-1.fc7.i386 
--> Running transaction check
--> Processing Dependency: epiphany >= 2.18.0 for package: epiphany-extensions
--> Finished Dependency Resolution
****   Failed 
****     Unresolveable requirement epiphany >= 2.18.0 for epiphany-extensions 
**** Checking for dep problems  : firefox - 2.0.0.4-2.fc7.i386 
--> Running transaction check
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox for package: gecko-sharp2
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 2.0.0.4 for package: liferea
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: firefox = 2.0.0.4-2.fc7 for package: firefox-devel
--> Processing Dependency: firefox > 1.99 for package: monodevelop
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Finished Dependency Resolution
****   Failed 
****     Unresolveable requirement firefox = 2.0.0.4 for blam 
****     Unresolveable requirement firefox = 2.0.0.4 for Democracy 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for galeon 
****     Unresolveable requirement firefox for gecko-sharp2 
****     Unresolveable requirement firefox = 2.0.0.4 for gnome-python2-gtkmozembed 
****     Unresolveable requirement firefox = 2.0.0.4 for liferea 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for yelp 
****     Unresolveable requirement firefox = 2.0.0.4-2.fc7 for firefox-devel 
****     Unresolveable requirement firefox > 1.99 for monodevelop 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for devhelp 
**** Checking for dep problems  : galeon - 2.0.3-10.fc7.i386 
--> Running transaction check
---> Package galeon.i386 0:2.0.3-10.fc7 set to be updated
--> Processing Dependency: gecko-libs = 1.8.1.5 for package: galeon
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package galeon.i386 0:2.0.3-10.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: firefox = 2.0.0.4 for package: liferea
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: firefox = 2.0.0.4-2.fc7 for package: firefox-devel
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: galeon
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: yelp
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: devhelp
--> Finished Dependency Resolution
****   Failed 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package blam 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package Democracy 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for galeon 
****     Missing Dependency: firefox = 2.0.0.4 is needed by package
gnome-python2-gtkmozembed 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for yelp 
****     Unresolveable requirement gecko-libs = 1.8.1.4 for devhelp 
**** Checking for dep problems  : yelp - 2.18.1-4.fc7.i386 
--> Running transaction check
****   OK : yelp.i386 0-2.18.1-4.fc7 - None
**** Checking for dep problems  : firefox - 2.0.0.5-1.fc7.i386 
--> Running transaction check
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
****   OK : firefox.i386 0-2.0.0.5-1.fc7 - u
**** Checking for dep problems  : devhelp - 0.13-8.fc7.i386 
--> Running transaction check
****   OK : devhelp.i386 0-0.13-8.fc7 - None
**** Packages with dependency resolving errors 
**** liferea - 1.2.19-3.fc7.i386 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
**** firefox-devel - 2.0.0.5-1.fc7.i386 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
**** devhelp - 0.13-9.fc7.i386 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
**** epiphany - 2.18.3-2.fc7.i386 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
**** yelp - 2.18.1-5.fc7.i386 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
**** epiphany - 2.18.3-1.fc7.i386 
****   2 
**** firefox - 2.0.0.4-2.fc7.i386 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
**** galeon - 2.0.3-10.fc7.i386 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
****   2 
**** End Checking packages for dependency problems
--> Running transaction check
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 firefox                 i386       2.0.0.5-1.fc7    updates            21 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total download size: 21 M
Is this ok [y/N]:

Normal update (yum update):
Loading "installonlyn" plugin
Loading "priorities" plugin
Loading "kernel-module" plugin
Loading "fastestmirror" plugin
Loading "security" plugin
Loading "skip-broken" plugin
Loading "changelog" plugin
Loading "allowdowngrade" plugin
Loading "fedorakmod" plugin
Loading "downloadonly" plugin
Loading "protectbase" plugin
Setting up Update Process
Loading mirror speeds from cached hostfile
71 packages excluded due to repository priority protections
Skipping security plugin, no data
0 packages excluded due to repository protections
Resolving Dependencies
Skipping security plugin, no data
--> Running transaction check
---> Package liferea.i386 0:1.2.19-3.fc7 set to be updated
---> Package firefox-devel.i386 0:2.0.0.5-1.fc7 set to be updated
---> Package devhelp.i386 0:0.13-9.fc7 set to be updated
---> Package epiphany.i386 0:2.18.3-2.fc7 set to be updated
---> Package yelp.i386 0:2.18.1-5.fc7 set to be updated
---> Package galeon.i386 0:2.0.3-10.fc7 set to be updated
---> Package firefox.i386 0:2.0.0.5-1.fc7 set to be updated
--> Processing Dependency: firefox = 2.0.0.4 for package: blam
--> Processing Dependency: firefox = 2.0.0.4 for package: Democracy
--> Processing Dependency: gecko-libs = 1.8.1.4 for package: epiphany-extensions
--> Processing Dependency: firefox = 2.0.0.4 for package: gnome-python2-gtkmozembed
--> Finished Dependency Resolution 
Error: Missing Dependency: firefox = 2.0.0.4 is needed by package blam
Error: Missing Dependency: firefox = 2.0.0.4 is needed by package Democracy
Error: Unresolveable requirement gecko-libs = 1.8.1.4 for epiphany-extensions
Error: Missing Dependency: firefox = 2.0.0.4 is needed by package
gnome-python2-gtkmozembed

Before the patch, with --skip-broken option, yum would try to install all broken
packages.
Comment 4 Tim Lauridsen 2008-03-12 11:53:58 EDT
yum >= 3.2.10 in current rawhide have much improved '--skip-broken' buildin, so
please try 

yum remove yum-skip-broken
yum install pygpgme
yum install --enablerepo=development update yum

to check it out. 


Note You need to log in before you can comment on or make changes to this bug.