Bug 248720 - policy no longer allows grub to run
Summary: policy no longer allows grub to run
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-18 13:29 UTC by Jeremy Katz
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: Current
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-22 14:15:17 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jeremy Katz 2007-07-18 13:29:50 UTC
grub needs to be allowed execmem (and used to be)

avc: denied { execmem } for comm="grub" egid=0 euid=0 exe="/sbin/grub" exit=-13
fsgid=0 fsuid=0 gid=0 items=0 pid=9454
scontext=system_u:system_r:unconfined_t:s0 sgid=0
subj=system_u:system_r:unconfined_t:s0 suid=0 tclass=process
tcontext=system_u:system_r:unconfined_t:s0 tty=pts4 uid=0

Comment 1 Daniel Walsh 2007-07-18 13:43:42 UTC
Currently grub (bootloader_t) has execmem but we do not have a transition from
unconfined_t.  It only transitions from init.  But it looks like this is true in
FC7 and Rawhide.

I will add the transition back to rawhide.  I believe there were other problems
with this transition in the past and that is why I turned it off, but I will
turn it back on and see what happens.  

Fixed in selinux-policy-3.0.3-1.fc8

Comment 2 Daniel Walsh 2007-08-22 14:15:17 UTC
Should be fixed in the current release



Note You need to log in before you can comment on or make changes to this bug.