Bug 248727 - Don't bounce Virtual Machine when adding as a managed VM service
Summary: Don't bounce Virtual Machine when adding as a managed VM service
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rgmanager
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
: 247801 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-18 13:52 UTC by Rob Kenna
Modified: 2009-04-16 22:37 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2007-11-07 16:46:19 UTC


Attachments (Terms of Use)
Patch (21.79 KB, patch)
2007-07-30 21:07 UTC, Lon Hohberger
no flags Details | Diff
Cleaned up patch (21.86 KB, patch)
2007-07-30 21:21 UTC, Lon Hohberger
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0580 normal SHIPPED_LIVE rgmanager bug fix and enhancement update 2007-10-30 15:37:24 UTC

Description Rob Kenna 2007-07-18 13:52:10 UTC
When adding an Cluster Managed Virtual Machine (VM) Service, rgmanager currently
restarts the VM as it does with other managed services.  This is likely to be an
unexpected event for a running virtualized OS instance.

Instead, for managing VM's we need to leave a running VM running.

Comment 3 Lon Hohberger 2007-07-24 14:52:08 UTC
This is a trivial fix.  Services which are tagged as migratory (e.g. they have
the 'migrate' action and have no children) can be ignored in do_condstops /
do_condstarts.

The next question is:

Do we stop the VM if you delete it from the cluster config or not?



Comment 4 Rob Kenna 2007-07-24 22:04:03 UTC
in answer to "Do we stop the VM if you delete it from the cluster config or not?
"

The answer is no.  Changing the management of the VM should not cause it to restart.

Comment 5 Lon Hohberger 2007-07-30 21:07:49 UTC
Created attachment 160273 [details]
Patch

This implements the required behavior and minimizes virtual machine
transitions.  If added or removed from the cluster configuration, virtual
machines no longer transition (though if desired, this can be altered). 
Additionally, if non-critical attributes of the virtual machine are altered,
the virtual machine is not restarted.

This patch has the side effect of fixing #247801.

Comment 6 Lon Hohberger 2007-07-30 21:21:06 UTC
Created attachment 160275 [details]
Cleaned up patch

Comment 7 Lon Hohberger 2007-07-30 21:31:14 UTC
*** Bug 247801 has been marked as a duplicate of this bug. ***

Comment 8 Lon Hohberger 2007-07-31 18:03:31 UTC
Patches in CVS

Comment 9 Rob Kenna 2007-07-31 21:50:59 UTC
On a node reboot, the guest correctly gets restarted on another node.  However,
once the node returns, rgmanager stops the guest and restarts it on the recovery
node.  Either it should use live migration to return it or leave it on the
failover node.  Setting to fails-qa

Comment 10 Lon Hohberger 2007-08-13 16:06:55 UTC
Rob, I checked in more patches for this before going on vacation - it should be
working now.  It's on your cluster.  Could you retest?

Comment 13 errata-xmlrpc 2007-11-07 16:46:19 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0580.html



Note You need to log in before you can comment on or make changes to this bug.