Bug 248741 - RHEL-5 is not capable of building contemporary Java packages: it lacks maven2
RHEL-5 is not capable of building contemporary Java packages: it lacks maven2
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ant (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: Deepak Bhole
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 10:39 EDT by Fernando Nasser
Modified: 2008-07-09 16:53 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-07-09 16:53:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Fernando Nasser 2007-07-18 10:39:54 EDT
Description of problem:

An increasing number of usptream Java projects are moving from Ant builds to
Maven builds.  Maven2 was only added to Fedora 7, so it is not present in the
RHEL 5.0 (or 5.1 Beta).  This prevents rebuilding many Java SRPMS on RHEL-5.

Version-Release number of selected component (if applicable):

Maven 2.0.4 and dependencies

How reproducible:

Always

Steps to Reproduce:
1. Attempt building a package that needs maven2 to build
2.
3.
  
Actual results:

maven2 and maven2 plugins not available

Expected results:

Package is built

Additional info:

The maven2 packages and its dependencies were added in an effort that involved
many developers to Fedora 7, and it is now in F-7 and in the F-8 development
branch.  The works is don, it is just a question of rebuilding that set of
packages on RHEL-5

These packages are additional, so there is no current package in RHEL-5 that
depends on them, so there is no concerns at all about backwards compatibility.
Comment 1 Deepak Bhole 2008-07-09 16:53:58 EDT
The package set will not be imported into RHEL-5 in the forseeable future due to
the significant maintenance overheard and fairly low advantage.

Marking WONTFIX. Feel free to re-open if maven2 becomes necessary in RHEL-5 in
the future.

Note You need to log in before you can comment on or make changes to this bug.