Bug 248765 - EPEL ports for bugzilla deps
EPEL ports for bugzilla deps
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: bugzilla (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: John Berninger
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 12:44 EDT by John Berninger
Modified: 2007-11-30 17:12 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 16:53:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
kevin: fedora‑cvs+


Attachments (Terms of Use)

  None (edit)
Description John Berninger 2007-07-18 12:44:20 EDT
Package Change Request
======================
Package Name: perl-Email-Reply, perl-Email-Send,
perl-Email-MIME-Attachment-Stripper, perl-Template-Toolkit, perl-Email-Simple,
perl-Email-MIME-Modifier,
perl-Email-Address, perl-Email-MIME
New Branches: EL-5
Updated Fedora CC: john@ncphotography.com
Updated EPEL Owners: john@ncphotography.com
Comment 1 John Berninger 2007-07-18 12:45:58 EDT
Package Change Request
======================
Package Name: perl-Email-Reply, perl-Email-Send,
perl-Email-MIME-Attachment-Stripper, perl-Template-Toolkit, perl-Email-Simple,
perl-Email-MIME-Modifier,
perl-Email-Address, perl-Email-MIME
New Branches: EL-4
Updated Fedora CC: john@ncphotography.com
Updated EPEL Owners: john@ncphotography.com

(sorry I missed EL4 originally, my copy/paste went awry)
Comment 2 Warren Togami 2007-07-18 14:39:57 EDT
Current owner of these packages is tcallawa@redhat.com.  Will you be taking over
entirely or will you both be owners?

Owners in Fedora will be different from EPEL?

Please clarify.  Thanks.
Comment 3 John Berninger 2007-07-18 14:45:51 EDT
Per EPEL policy
(http://fedoraproject.org/wiki/EPEL/FAQ#head-4abf2d9b3e246e2b96746da2867c2436c42351d4),
I requested these builds with me as EPEL co-maintainer since I've gotten no
responses on BZ's 242926 and 242931.  I do not wish to take over the packages
completely, as I assume the current Fedora maintainers will eventually return to
maintain the packages, but I need the EPEL ports to resolve dependency issues
for bugzilla.
Comment 4 Tom "spot" Callaway 2007-07-19 12:41:39 EDT
I don't own the following BuildRequires, and they are not built/owned in EPEL:

perl-AppConfig (jpo)
perl-DateTime-Format-Mail (cweyl@alumni.drew.edu)
perl-Email-Address (jpo)
perl-Email-MIME (jpo)
perl-Email-MIME-ContentType (jpo)
perl-Email-MIME-Modifier (jpo)
perl-Email-Simple (jpo)
perl-File-Remove (rc040203@freenet.de,lxtnow@gmail.com)
perl-GDGraph3d (jpo)
perl-HTML-Format (rc040203@freenet.de,lxtnow@gmail.com)
perl-Image-Info (jpo)
perl-Image-Size (jpo)
perl-MIME-Types (ville.skytta@iki.fi)
perl-Parse-RecDescent (rnorwood@redhat.com)
perl-Time-Piece (chris@chrisgrau.com) (Chris, perl(Time::Piece) is also being
provided incorrectly by perl-Time-Piece-MySQL)
perl-Test-Differences (jpo)
perl-Test-Manifest (jpo)
perl-Test-Perl-Critic (jpo)
perl-Test-Pod (jpo)
perl-XML-XPath (cweyl@alumni.drew.edu)

I'd need all of these built for EPEL (EL-4 and EL-5) before I could do the
requested package builds.
Comment 5 Ville Skyttä 2007-07-23 13:23:28 EDT
perl-MIME-Types maintainer change is in progress, see bug 249309
Comment 6 Chris Weyl 2007-07-24 12:29:13 EDT
I'm rather constrained at the moment -- I'm willing to branch & build
perl-DateTime-Format-Mail and perl-XML-XPath for EPEL, but it would probably be
better if someone willing to own these branches in EPEL (or take over the
package entirely) stepped up.
Comment 7 Chris Weyl 2007-07-26 17:50:55 EDT
Transferring ownership of perl-DateTime-Format-Mail (bug 201477) and
perl-XML-XPath (bug 249455) to rnorwood.  Thanks Robin! :)
Comment 8 Robin Norwood 2007-07-27 10:02:13 EDT
I'll build them once they are branched.
Comment 9 Jason Tibbitts 2007-07-27 19:15:42 EDT
So what is actually needed of the CVS admins at this point?
Comment 10 Robin Norwood 2007-07-30 16:10:44 EDT
Nothing from me.  I don't know if John needs anything still or not.  This bug
got a bit hijacked, looks like.
Comment 11 Kevin Fenzi 2007-07-30 19:00:22 EDT
Setting fedora-cvs to - here for now. Please reset to ? if you need anything
from cvsadmins. 
Comment 12 Chris Grau 2007-08-03 20:57:58 EDT
Package Change Request
======================
Package Name: perl-Time-Piece, perl-Time-Piece-MySQL
New Branches: EL-4 EL-5

(Sorry if this isn't the appropriate place to request this.  I'll open a new bug
if necessary.)
Comment 13 Kevin Fenzi 2007-08-04 02:21:58 EDT
This is fine. cvs done. 
Comment 14 Tom "spot" Callaway 2007-11-21 16:53:49 EST
According to Rob Myers, the last missing EPEL dependencies for bugzilla were
mine, and they're all now built for EL-5. Closing out this bug.

Note You need to log in before you can comment on or make changes to this bug.