This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 248821 - ADSL does not work in dom0
ADSL does not work in dom0
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
7
i686 Linux
low Severity high
: ---
: ---
Assigned To: Herbert Xu
Fedora Extras Quality Assurance
:
: 244085 248822 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-18 19:44 EDT by Arik Raffael Funke
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 2.6.20-2931.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-24 01:36:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
[PACKET]: Remove skb_checksum_setup (829 bytes, patch)
2007-08-09 05:32 EDT, Herbert Xu
no flags Details | Diff

  None (edit)
Description Arik Raffael Funke 2007-07-18 19:44:20 EDT
Description of problem:
Adsl connection that works flawlessly on a system started with a non-xen kernel 
ceases to work when system is started with xen-kernel as dom0. The system is 
CLEAN and there are NO configuration/environment changes between the two 
situations EXCEPT the choice of the kernel during grub-stage.

Steps to Reproduce:
1. Clean install of Fedora 7 with virtualisation option
2. Start with non-xen kernel and setup adsl (i.e. connect to a adsl modem via a 
network card). This works flawlessly.
3. Restart with xen-kernel into dom0
4. Retry to connect with adsl: impossible


Demonstration:

In non-xen kernel: (adsl works)
===============================
[root@gaia ~]# pppoe -I eth0 -A
Access-Concentrator: ULMC03-10k
Got a cookie: ea 64 c2 d8 c9 f6 70 96 72 27 c2 72 eb 23 fb 1d
AC-Ethernet-Address: 00:19:e8:6e:70:31
--------------------------------------------------
[root@gaia ~]#


In xen-kernel, dom0: (adsl does not work)
=========================================
[root@gaia ~]# pppoe -I eth0 -A
pppoe: Timeout waiting for PADO packets
[root@gaia ~]# 



In /var/messages it says (in dom0 where adsl connection fails):

Jul 17 00:08:21 gaia pppd[3494]: pppd 2.4.4 started by root, uid 0
Jul 17 00:08:21 gaia pppd[3494]: Using interface ppp0
Jul 17 00:08:21 gaia pppd[3494]: Connect: ppp0 <--> /dev/pts/1
Jul 17 00:08:52 gaia pppd[3494]: LCP: timeout sending Config-Requests
Jul 17 00:08:52 gaia pppd[3494]: Connection terminated.
Jul 17 00:08:52 gaia pppd[3494]: Modem hangup
Jul 17 00:08:56 gaia pppoe[3495]: Timeout waiting for PADO packets
Jul 17 00:08:56 gaia pppd[3494]: Exit.
Jul 17 00:08:56 gaia pppoe-connect: PPPoE connection lost; attempting re-
connection.
Jul 17 00:09:01 gaia pppd[3569]: pppd 2.4.4 started by root, uid 0
Jul 17 00:09:01 gaia pppd[3569]: Using interface ppp0
Jul 17 00:09:01 gaia pppd[3569]: Connect: ppp0 <--> /dev/pts/1
Jul 17 00:09:32 gaia pppd[3569]: LCP: timeout sending Config-Requests
Jul 17 00:09:32 gaia pppd[3569]: Connection terminated.
Jul 17 00:09:32 gaia pppd[3569]: Modem hangup
Jul 17 00:09:36 gaia pppoe[3570]: Timeout waiting for PADO packets
Jul 17 00:09:36 gaia pppd[3569]: Exit.
Comment 1 Arik Raffael Funke 2007-07-18 19:46:28 EDT
*** Bug 248822 has been marked as a duplicate of this bug. ***
Comment 2 Herbert Xu 2007-07-18 20:57:51 EDT
What does ifconfig say in the xen kernel just before you start pppoe? Thanks.
Comment 3 Arik Raffael Funke 2007-07-19 11:13:08 EDT
Following is straight from the terminal on the xen kernel:

[root@gaia ~]# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:C1:26:11:BD:EF  
          inet6 addr: fe80::2c1:26ff:fe11:bdef/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:4623 (4.5 KiB)
          Interrupt:20 Base address:0xc000 

eth1      Link encap:Ethernet  HWaddr 00:11:D8:41:18:71  
          inet6 addr: fe80::211:d8ff:fe41:1871/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:81 errors:0 dropped:0 overruns:0 frame:0
          TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:5663 (5.5 KiB)  TX bytes:6273 (6.1 KiB)
          Interrupt:19 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:7131 errors:0 dropped:0 overruns:0 frame:0
          TX packets:7131 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:40878352 (38.9 MiB)  TX bytes:40878352 (38.9 MiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:4281 (4.1 KiB)

[root@gaia ~]# pppoe -I eth0 -A
pppoe: Timeout waiting for PADO packets
[root@gaia ~]# 
Comment 4 Roman Kisilenko 2007-07-19 20:12:06 EDT
The same issue described at
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=244085
Comment 5 Arik Raffael Funke 2007-07-20 03:59:53 EDT
I agree. This could probably marked as a duplicate of 244085 but as it has 
already been assigned to Herbert Xu, I am going to leave it to him to do so.
Comment 6 Herbert Xu 2007-07-25 01:55:23 EDT
What does brctl show say?
Comment 7 Roman Kisilenko 2007-08-02 20:11:07 EDT
(In reply to comment #6)
> What does brctl show say?

I would really like to help to resolve this bug to the most degree I can. I can
provide the required information to you instead of Arik if it is acceptable.
Comment 8 Herbert Xu 2007-08-03 07:13:12 EDT
Sure.  Please provide the ifconfig output too.  Thanks!
Comment 9 Roman Kisilenko 2007-08-07 11:17:01 EDT
Ok, got some time today to get the info. The bug is quite easy to reproduce. 

1. Installed clean fedora 7 from DVD, disabled office and productivity group,
enabled virtualization group.
2. Booted up in NON-xen kerneel.
3. Set up pppoe. Connection successfull.
4. Updated the system.
5. Rebooted into NON-xen kernel. PPPOE onnection still works.
[user@localhost ~]$ /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:60:52:45:A5:34
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::260:52ff:fe45:a534/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:128 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:7680 (7.5 KiB)  TX bytes:9384 (9.1 KiB)
          Interrupt:17 Base address:0xa000 

eth1      Link encap:Ethernet  HWaddr 00:16:E6:6B:4B:AE  
          inet6 addr: fe80::216:e6ff:fe6b:4bae/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:359 errors:0 dropped:0 overruns:0 frame:0
          TX packets:262 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:50224 (49.0 KiB)  TX bytes:33852 (33.0 KiB)
          Interrupt:23 Base address:0x6000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4299 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4299 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:25040160 (23.8 MiB)  TX bytes:25040160 (23.8 MiB)

ppp0      Link encap:Point-to-Point Protocol  
          inet addr:87.228.71.251  P-t-P:83.217.192.140  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:217 errors:0 dropped:0 overruns:0 frame:0
          TX packets:221 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3 
          RX bytes:35949 (35.1 KiB)  TX bytes:22149 (21.6 KiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:47 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:9118 (8.9 KiB)
[user@localhost ~]$ /usr/sbin/brctl show
bridge name     bridge id               STP enabled     interfaces
virbr0          8000.000000000000       no

6. Rebooted into xen kernel. PPPOE does NOT work.
[rkisilenko@localhost ~]$ /sbin/ifconfig
eth0      Link encap:Ethernet  HWaddr 00:60:52:45:A5:34  
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::260:52ff:fe45:a534/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:223 errors:0 dropped:0 overruns:0 frame:0
          TX packets:50 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:13380 (13.0 KiB)  TX bytes:9180 (8.9 KiB)
          Interrupt:17 Base address:0xa000 

eth1      Link encap:Ethernet  HWaddr 00:16:E6:6B:4B:AE  
          inet6 addr: fe80::216:e6ff:fe6b:4bae/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:482 errors:1 dropped:0 overruns:0 frame:0
          TX packets:34 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:39878 (38.9 KiB)  TX bytes:5123 (5.0 KiB)
          Interrupt:23 Base address:0x2000 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4918 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4918 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:15832676 (15.0 MiB)  TX bytes:15832676 (15.0 MiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:41 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:8570 (8.3 KiB)
[user@localhost ~]$ /usr/sbin/brctl show
bridge name     bridge id               STP enabled     interfaces
tmpbridge               8000.000000000000       no
virbr0          8000.000000000000       no
From syslog:
Aug  7 19:00:06 localhost pppd[3174]: pppd 2.4.4 started by root, uid 0
Aug  7 19:00:06 localhost pppd[3174]: Using interface ppp0
Aug  7 19:00:06 localhost pppd[3174]: Connect: ppp0 <--> /dev/pts/1
Aug  7 19:00:37 localhost pppd[3174]: LCP: timeout sending Config-Requests 
Aug  7 19:00:37 localhost pppd[3174]: Connection terminated.
Aug  7 19:00:37 localhost pppd[3174]: Modem hangup
Aug  7 19:00:41 localhost pppoe[3175]: Timeout waiting for PADO packets
Aug  7 19:00:41 localhost pppd[3174]: Exit.
Comment 10 Herbert Xu 2007-08-07 19:38:57 EDT
*** Bug 244085 has been marked as a duplicate of this bug. ***
Comment 11 Herbert Xu 2007-08-09 05:32:59 EDT
Created attachment 160958 [details]
[PACKET]: Remove skb_checksum_setup

The skb_checksum_setup calls need to be removed now that it's called earlier.
Comment 12 Eduardo Habkost 2007-08-09 16:34:14 EDT
There is no skb_checksum_setup() calls on af_packet.c anymore, after the xen 
patch was updated to xen 3.1.0, on kernel-xen-2.6-2.6.20-2925.14.fc7 (that 
just went to updates-testing).

Could you test kernel-xen-2.6-2.6.20-2925.14.fc7 from F-7 updates-testing 
repository?
Comment 13 Roman Kisilenko 2007-08-11 12:34:45 EDT
Thank you, kernel-xen-2.6-2.6.20-2925.14.fc7 from F-7 updates-testing works for
me in dom0. Going to check it in domU also.
Comment 14 Fedora Update System 2007-08-13 13:02:22 EDT
kernel-xen-2.6-2.6.20-2931.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2007-08-24 01:36:25 EDT
kernel-xen-2.6-2.6.20-2931.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.