Bug 248833 - Fails to access LDAP directory servers (64-bit issue)
Summary: Fails to access LDAP directory servers (64-bit issue)
Status: CLOSED DUPLICATE of bug 243296
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution-data-server   
(Show other bugs)
Version: 7
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-19 02:20 UTC by Henrik Nordström
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-19 03:59:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Henrik Nordström 2007-07-19 02:20:01 UTC
Description of problem:

x86_64 version fails to find any contacts in LDAP directories

i386 version works fine.

Version-Release number of selected component (if applicable):

evolution-data-server-1.10.3-1.fc7.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Configure evolution with an LDAP address book
2. Try searching for a contact
3. 
  
Actual results:

No contacts returned
Additioally the following error is found on the terminal starting evolution
(only if evolution-data-server is not yet running)
(evolution:6230): evolution-addressbook-WARNING **: error loading addressbook :
e_book_new: no factories available for URI
`ldap://henriknordstrom.net:389/dc=henriknordstrom,dc=net??sub?'


Expected results:

Should find the contacts

Additional info:

A workaround is to use the i386 evolution-data-server binary.

cd /
rpm2cpio ~/evolution-data-server-1.10.3-1.fc7.i386.rpm | cpio -idmvu
pkill evolution

(instllalling with rpm is not possible as the x86_64 package provides shared
libraries used by many components).

Fedora 6 version also works fine (x86_64).

Comment 1 Matthew Barnes 2007-07-19 02:41:37 UTC
This might be related to bug #243296.

Can you try upgrading to evolution-data-server-1.10.3-2.fc7, which is available
now in Updates Testing?

Comment 2 Henrik Nordström 2007-07-19 03:59:00 UTC
Upgraded to evolution & evolution-data-server from upgrades-testing and things
seems to work fine.

 evolution               x86_64     2.10.3-2.fc7     updates-testing    37 M
 evolution-data-server   x86_64     1.10.3.1-2.fc7   updates-testing   3.6 M

and yes, i remembered to have evolution-data-server restarted after the upgrade.

*** This bug has been marked as a duplicate of 243296 ***


Note You need to log in before you can comment on or make changes to this bug.