Bug 24884 - rpm -Va finds missing and mismatching files
rpm -Va finds missing and mismatching files
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 16:14 EST by Robert M. Riches Jr.
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-24 16:15:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert M. Riches Jr. 2001-01-24 16:14:59 EST
After installing RedHat 7 Alpha Deluxe, then installing a bunch of RPMs
from the documentation CD, then using up2date to update everything,
I am seeing a large number of missing and mismatching files.  Is this
normal, or does this indicate a problem?  (On a previous installation,
some terminfo files were missing, which has been solved separately.)

Some mismatching files are obviously configuration items, such as
/etc/passwd.  I imagine the /dev/ files are probably a non-issue. The
one documentation file from Powertools appears to be shared from
several rpms, so I understand about it.  However, others appear to be
possible problems.

Thanks.

Robert Riches
richesr1@inetarena.com

At the risk of being excessively verbose, here's the output from
rpm -Va, all 117 of them:

..5....T c /etc/mime.types
missing    /var/log/mars_nwe.log
missing    /var/run/mars_nwe.routes
.......T   /etc/X11/applnk/Documentation/Linux Community/howto.desktop
SM5....T c /etc/X11/fs/config
S.5....T   /boot/kernel.h-2.2.17
.......T c /etc/krb5.conf
.......T   /etc/X11/applnk/Documentation/Linux Community/howto.desktop
missing    /var/log/mysqld.log
S.5....T c /etc/pam.d/system-auth
S.5....T c /etc/syslog.conf
.......T c /etc/inittab
SM5....T c /etc/rc.d/rc.local
S.5....T   /usr/share/AbiSuite/fonts/fonts.dir
.M......   /var/spool/at/.SEQ
.M......   /dev/audio
.M......   /dev/audio1
.M......   /dev/audioctl
.M......   /dev/dsp
.M......   /dev/dsp1
.M....G.   /dev/dsp56k
.M......   /dev/fd0D360
.M......   /dev/fd0D720
.M......   /dev/fd0H1440
.M......   /dev/fd0H360
.M......   /dev/fd0H720
.M......   /dev/fd1D360
.M......   /dev/fd1D720
.M......   /dev/fd1H1440
.M......   /dev/fd1H360
.M......   /dev/fd1H720
.M......   /dev/hda
.M......   /dev/jsflash
.M......   /dev/midi0
.M......   /dev/midi00
.M......   /dev/midi01
.M......   /dev/midi02
.M......   /dev/midi03
.M......   /dev/midi1
.M......   /dev/midi2
.M......   /dev/midi3
.M......   /dev/mixer
.M......   /dev/mixer1
......G.   /dev/radio0
......G.   /dev/radio1
......G.   /dev/radio2
......G.   /dev/radio3
.M......   /dev/scd0
.M......   /dev/scd1
.M......   /dev/sequencer
.....UG.   /dev/tty0
......G.   /dev/tty1
......G.   /dev/tty2
......G.   /dev/tty3
......G.   /dev/tty4
......G.   /dev/tty5
......G.   /dev/tty6
.....UG.   /dev/tty7
.....UG.   /dev/tty8
......G.   /dev/vbi0
......G.   /dev/vbi1
......G.   /dev/vbi2
......G.   /dev/vbi3
.....U..   /dev/vcs1
.....U..   /dev/vcs2
.....U..   /dev/vcsa1
.....U..   /dev/vcsa2
......G.   /dev/video0
......G.   /dev/video1
......G.   /dev/video2
......G.   /dev/video3
......G.   /dev/vtx
......G.   /dev/vtx0
......G.   /dev/vtx1
......G.   /dev/vtx2
......G.   /dev/vtx3
......G.   /dev/winradio0
......G.   /dev/winradio1
......G.   /dev/winradio2
......G.   /dev/winradio3
S.5....T c /usr/share/emacs/site-lisp/site-start.el
.......T   /usr/share/pixmaps/gnome-irc.png
.......T   /usr/share/pixmaps/netscape.png
S.5....T   /usr/share/umb-scheme/slibcat
SM5....T c /etc/conf.linuxconf
SM5....T   /usr/X11R6/lib/X11/fonts/Speedo/encodings.dir
.M.....T   /usr/X11R6/lib/X11/fonts/Speedo/fonts.dir
S.5....T   /usr/X11R6/lib/X11/fonts/misc/fonts.dir
.......T   /etc/X11/applnk/Documentation/Linux Community/howto.desktop
.M...... c /etc/group
.M...... c /etc/motd
.M...... c /etc/passwd
SM5....T c /etc/printcap
......G.   /etc/aliases.db
SM5....T c /etc/mail/sendmail.mc
S.5....T c /etc/sendmail.cf
S.5....T c /etc/php.ini
.......T   /etc/X11/applnk/Documentation/Linux Community/howto.desktop
S.5....T   /usr/share/rhn/up2date/config.pyc
S.5....T   /usr/share/rhn/up2date/translate.pyc
S.5....T   /usr/share/rhn/up2date/up2date.pyc
S.5....T   /usr/lib/python1.5/site-packages/cgiwrap.pyc
S.5....T   /usr/lib/python1.5/site-packages/xmlrpclib.pyc
.......T c /etc/yp.conf
SM5....T c /etc/ntp.conf
SM5....T c /etc/ntp/keys
missing    /etc/ntp/step-tickers
.......T   /etc/X11/applnk/Documentation/Linux Community/howto.desktop
missing    /usr/share/ssl/certs/stunnel.pem
S.5....T   /usr/share/rhn/up2date/checklist.pyc
S.5....T   /usr/share/rhn/up2date/gui.pyc
S.5....T   /usr/share/rhn/up2date/progress.pyc
S.5....T c /etc/crontab
.......T   /usr/share/toolbar/down.xpm
.......T   /usr/share/toolbar/up.xpm
S.5....T   /usr/share/texmf/ls-R
.......T   /etc/X11/applnk/Documentation/Linux Community/howto.desktop
Comment 1 Jeff Johnson 2001-01-25 17:21:15 EST
Yes, many files are changed when installed and/or used, and rpm detects that.
You need
to look carefully at the reasons for the change and report significant changes
as bugs against
specific packages, as this is not an rpm problem.
Comment 2 Robert M. Riches Jr. 2001-01-25 17:33:20 EST
My only remaining question is how is a clueless newbie such as myself to
determine with any confidence which changes are benign and which are
significant?  In my first round of installing Redhat 7 and using Update
Agent to get the latest security advisories and bug fixes, I was left without
a .../terminfo/x/xterm file, among a few others.  For most of the files rpm
shows as changed, I haven't a clue whether they are benign or whether
they will cause some interesting application to misbehave in strange ways
at some point in the future.  Can you provide a pointer to suggestions on
how to make this determination?

Thanks.

Robert Riches
richesr1@inetarena.com

Note You need to log in before you can comment on or make changes to this bug.