Bug 248852 - rt61pci module does not work with RaLink RT2561/RT61 802.11g PCI
rt61pci module does not work with RaLink RT2561/RT61 802.11g PCI
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-19 04:16 EDT by Nadav Kavalerchik
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 15:48:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nadav Kavalerchik 2007-07-19 04:16:25 EDT
Description of problem:

after a fresh install of a fc7 system, wireless RaLink rt61 does not function
although module is loaded into memory the wlan0 interface is not recognized 
(created) with ifconfig,iwconfig,iwlist.

removing it from kernel tree and installing the rt61-cvs-daily.tar.gz from 
rt2x00.serialmonkey.com site solve the issue :-)

Version-Release number of selected component (if applicable):
rt61pci - 2.6.21-1.3194.fc7 SMP mod_unload 686 4KSTACKS

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

unfortunately i get these crashes when i power off the machine:

NetworkManager: <WARN>  nm_signal_handler(): Caught signal 15, shutting down 
normally. 
Jul 19 00:32:27 localhost NetworkManager: <info>  Caught terminiation signal 
Jul 19 00:32:27 localhost NetworkManager: <info>  Deactivating device wlan0. 
Jul 19 00:32:27 localhost NetworkManager: <WARN>  
nm_device_802_11_wireless_set_wep_enc_key(): error setting key for device 
wlan0: Invalid argument 
Jul 19 00:32:27 localhost kernel: ------------[ cut here ]------------
Jul 19 00:32:27 localhost kernel: kernel BUG at include/linux/timer.h:147!
Jul 19 00:32:27 localhost kernel: invalid opcode: 0000 [#1]
Jul 19 00:32:27 localhost kernel: SMP 
Jul 19 00:32:27 localhost kernel: last sysfs 
file: /devices/pci0000:00/0000:00:02.0/enable
Jul 19 00:32:27 localhost kernel: Modules linked in: rt61(U) vfat fat ext2 
usb_storage i915 drm autofs4 hidp rfcomm l2cap bluetooth sunrpc acpi_cpufreq 
dm_multipath video sbs i2c_ec button bay dock battery ac ipv6 lp loop 
snd_hda_intel snd_hda_codec snd_seq_dummy snd_seq_oss snd_seq_midi_event 
snd_seq snd_seq_device 8139too r8169 snd_pcm_oss 8139cp mii snd_mixer_oss 
serio_raw snd_pcm snd_timer snd sr_mod soundcore cdrom snd_page_alloc floppy 
i2c_i801 iTCO_wdt i2c_core iTCO_vendor_support pcspkr parport_pc parport sg 
dm_snapshot dm_zero dm_mirror dm_mod ata_piix ata_generic libata sd_mod 
scsi_mod ext3 jbd mbcache ehci_hcd ohci_hcd uhci_hcd
Jul 19 00:32:27 localhost kernel: CPU:    1
Jul 19 00:32:27 localhost kernel: EIP:    0060:[<f90e6241>]    Not tainted VLI
Jul 19 00:32:27 localhost kernel: EFLAGS: 00010282   (2.6.21-1.3194.fc7 #1)
Jul 19 00:32:27 localhost kernel: EIP is at LinkDown+0xe3/0x341 [rt61]
Jul 19 00:32:27 localhost kernel: eax: f06491e8   ebx: f0640000   ecx: 
00000000   edx: 00000068
Jul 19 00:32:27 localhost kernel: esi: f06494fc   edi: f064951e   ebp: 
00000000   esp: f019dbec
Jul 19 00:32:27 localhost kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  
ss: 0068
Jul 19 00:32:27 localhost kernel: Process NetworkManager (pid: 4731, 
ti=f019d000 task=f11227d0 task.ti=f019d000)
Jul 19 00:32:27 localhost kernel: Stack: f0b88000 f0640000 f0b88000 00000000 
f90de823 f0b88000 00011042 00001003 
Jul 19 00:32:27 localhost kernel:        c05a24e4 f0b88000 c05a19e1 f7448e10 
ffffffed 00000000 f0b88000 c05a977b 
Jul 19 00:32:27 localhost kernel:        00000000 c07150a0 f7448e10 00000000 
00000000 00000000 00000000 00000000 
Jul 19 00:32:27 localhost kernel: Call Trace:
Jul 19 00:32:27 localhost kernel:  [<f90de823>] rt61_close+0x14/0xd1 [rt61]
Jul 19 00:32:27 localhost kernel:  [<c05a24e4>] dev_close+0x48/0x61
Jul 19 00:32:27 localhost kernel:  [<c05a19e1>] dev_change_flags+0x47/0xe4
Jul 19 00:32:27 localhost kernel:  [<c05a977b>] rtnl_setlink+0x264/0x365
Jul 19 00:32:27 localhost kernel:  [<c05b5e3c>] netlink_dump_start+0x103/0x120
Jul 19 00:32:27 localhost kernel:  [<c05a9517>] rtnl_setlink+0x0/0x365
Jul 19 00:32:27 localhost kernel:  [<c05a8dad>] rtnetlink_rcv_msg+0x1c1/0x1e6
Jul 19 00:32:27 localhost kernel:  [<c05b4e19>] netlink_run_queue+0x50/0xbe
Jul 19 00:32:27 localhost kernel:  [<c05a8bec>] rtnetlink_rcv_msg+0x0/0x1e6
Jul 19 00:32:27 localhost kernel:  [<c05a8bab>] rtnetlink_rcv+0x25/0x3d
Jul 19 00:32:27 localhost kernel:  [<c05b51b6>] netlink_data_ready+0x12/0x4c
Jul 19 00:32:27 localhost kernel:  [<c05b426a>] netlink_sendskb+0x19/0x30
Jul 19 00:32:27 localhost kernel:  [<c05b5198>] netlink_sendmsg+0x277/0x283
Jul 19 00:32:27 localhost kernel:  [<c0599180>] sock_sendmsg+0xd0/0xeb
Jul 19 00:32:27 localhost kernel:  [<c0436e71>] 
autoremove_wake_function+0x0/0x35
Jul 19 00:32:27 localhost kernel:  [<c0436e71>] 
autoremove_wake_function+0x0/0x35
Jul 19 00:32:27 localhost kernel:  [<c04e7100>] copy_from_user+0x3a/0x66
Jul 19 00:32:27 localhost kernel:  [<c059932d>] sys_sendmsg+0x192/0x1f7
Jul 19 00:32:27 localhost kernel:  [<c0599e0d>] sys_recvmsg+0x1b9/0x1cd
Jul 19 00:32:27 localhost kernel:  [<c040592c>] reschedule_interrupt+0x28/0x30
Jul 19 00:32:27 localhost kernel:  [<c05900d8>] 
cpufreq_frequency_table_target+0x19/0x14a
Jul 19 00:32:27 localhost kernel:  [<c04638d2>] do_wp_page+0x381/0x3bc
Jul 19 00:32:27 localhost kernel:  [<c059a0d6>] sys_getsockname+0x9f/0xb0
Jul 19 00:32:27 localhost kernel:  [<c059adb6>] release_sock+0x12/0x9d
Jul 19 00:32:27 localhost kernel:  [<c0464cde>] __handle_mm_fault+0x888/0x8f3
Jul 19 00:32:27 localhost kernel:  [<c059a4fc>] sys_socketcall+0x240/0x261
Jul 19 00:32:27 localhost kernel:  [<c0404f70>] syscall_call+0x7/0xb
Jul 19 00:32:27 localhost kernel:  =======================
Jul 19 00:32:27 localhost kernel: Code: 00 75 09 c6 83 24 3a 01 00 00 eb 2b a1 
00 bc 70 c0 05 10 27 00 00 83 bb e8 91 00 00 00 89 83 f0 91 00 00 8d 83 e8 91 
00 00 74 04 <0f> 0b eb fe 8b 50 08 e8 75 85 34 c7 0f b6 8b b0 94 00 00 8d 93 
Jul 19 00:32:27 localhost kernel: EIP: [<f90e6241>] LinkDown+0xe3/0x341 [rt61] 
SS:ESP 0068:f019dbec
Comment 1 Nadav Kavalerchik 2007-07-19 08:51:54 EDT
i've been looking in /var/log/messages and i found out that rt61pci
was not loaded in the first place (just after a fresh install) because it was
missing firmware :-( , which was later installed by the rt61 module.
"rt2x00lib->rt2x00lib_load_firmware_continued: Error - Failed to read Firmware"

so i switched back.
now, rt61pci loads, generate wlan0 and wmaster0, finds an AP but does not really
connects to it.

here is part of the log file:
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:18:39:bc:52:67
wlan0: authenticate with AP 00:18:39:bc:52:67
wlan0: authenticate with AP 00:18:39:bc:52:67
wlan0: authentication with AP 00:18:39:bc:52:67 timed out

once again, i switch to rt61... and it works easily with "ifup wlan0"
Comment 2 John W. Linville 2007-07-19 09:06:46 EDT
Have you tried using NetworkManager?

Use system-config-network and un-check "Activate device when computer starts".  
Save and exit, then issue the following commands:

   service network restart
   service NetworkManager start

If you are using gnome, then you should see the NetworkManager icon in the top 
right of your screen -- it is reasonably simple to use, I doubt if you will 
have problems understanding the interface.

Is this any more successful at getting a usable wireless connection?  If so 
and you want to make it permanent, then issues this command:

   chkconfig NetworkManager on

Hth!  Let me know...
Comment 3 Nadav Kavalerchik 2007-07-19 09:29:40 EDT
here are the log entries after issuing "service network restart"

Loading module: rt2x00lib - CVS (N/A) by http://rt2x00.serialmonkey.com.
Loading module: rt2x00pci - CVS (N/A) by http://rt2x00.serialmonkey.com.
Loading module: rt61pci - CVS (N/A) by http://rt2x00.serialmonkey.com.
ACPI: PCI Interrupt 0000:06:02.0[A] -> GSI 18 (level, low) -> IRQ 18
wmaster0: Selected rate control algorithm 'simple'
ADDRCONF(NETDEV_UP): wlan0: link is not ready
IPv6 over IPv4 tunneling driver
sit0: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: Initial auth_alg=0
wlan0: authenticate with AP 00:18:39:bc:52:67
wlan0: RX authentication from 00:18:39:bc:52:67 (alg=0 transaction=2 status=0)
wlan0: authenticated
wlan0: associate with AP 00:18:39:bc:52:67
wlan0: RX AssocResp from 00:18:39:bc:52:67 (capab=0x1 status=0 aid=2)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: No ProbeResp from current AP 00:18:39:bc:52:67 - assume out of range
wlan0: no IPv6 routers present
wlan0: No STA entry for own AP 00:18:39:bc:52:67
wlan0: No STA entry for own AP 00:18:39:bc:52:67
r8169: eth1: link down
r8169: eth1: link down
ADDRCONF(NETDEV_UP): eth1: link is not ready
eth0: link down
ADDRCONF(NETDEV_UP): eth0: link is not ready
wlan0: No STA entry for own AP 00:18:39:bc:52:67
ADDRCONF(NETDEV_UP): wlan0: link is not ready

i also tried NetworkManager, here is what the log says:
Jul 19 16:12:23 ltsp dhclient: wmaster0: unknown hardware address type 801
Jul 19 16:12:23 ltsp dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Jul 19 16:12:24 ltsp kernel: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Jul 19 16:12:24 ltsp NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 1
Jul 19 16:12:29 ltsp dhclient: DHCPREQUEST on wlan0 to 255.255.255.255 port 67
Jul 19 16:12:42 ltsp dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
interval 8
Jul 19 16:12:50 ltsp dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
interval 20
Jul 19 16:13:10 ltsp dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
interval 14
Jul 19 16:13:24 ltsp dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
interval 18
Jul 19 16:13:42 ltsp dhclient: DHCPDISCOVER on wlan0 to 255.255.255.255 port 67
interval 1
Jul 19 16:13:43 ltsp dhclient: No DHCPOFFERS received.
Jul 19 16:13:43 ltsp dhclient: Trying recorded lease 192.168.1.102
Jul 19 16:13:46 ltsp NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0
Jul 19 16:13:46 ltsp NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0
Jul 19 16:14:10 ltsp NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 1
Jul 19 16:14:10 ltsp NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 1
Jul 19 16:14:10 ltsp kernel: ADDRCONF(NETDEV_UP): wlan0: link is not ready
Jul 19 16:14:10 ltsp NetworkManager: <info>  nm-netlink-monitor.c -
nm_netlink_monitor_event_handler (724) netlink reports device wlan0 link now 0

(btw.
 the "Recorded lease" if from an old lease!!!, so it's not really getting an IP)
Comment 4 Luis Felipe Marzagao 2007-07-26 10:30:12 EDT
Hello, guys. I did a fresh install of F7 and updated the whole system. Now I´m
running kernel 2.6.22. I realize F7 already comes with rt61 modules. So I just
copied the manufacture firmwares to /lib/firmware and got it up and running with
NetworkManager and with WPA.

BUT the connection drops a lot and it keeps trying to reconnect. It´s very unstable.

I was not able to compile the latest driver though
(http://rt2x00.serialmonkey.com/rt2x00-cvs-daily.tar.gz). I get this error:

[gustavo@localhost rt2x00-cvs-2007072523]$ make && echo ok
  CC [M]  /home/gustavo/rt2x00-cvs-2007072523/eeprom_93cx6/eeprom_93cx6.o
In file included from <command line>:1:
/home/gustavo/rt2x00-cvs-2007072523/rt2x00_compat.h:56:2: error: #error mac80211
debugfs support has been disabled in your kernel!
make[2]: ** [/home/gustavo/rt2x00-cvs-2007072523/eeprom_93cx6/eeprom_93cx6.o] Erro 1
make[1]: ** [_module_/home/gustavo/rt2x00-cvs-2007072523] Erro 2
make: ** [default] Erro 2

My experiments are being reported here:

http://www.fedoraforum.org/forum/showthread.php?p=835618#post835618


Should the compile error be reported as a bug?

Thanks a lot!
Comment 5 John W. Linville 2007-07-26 10:42:20 EDT
Feel free to report that as a bug to the rt2x00 team -- I have no idea why 
they depend on debugfs support in mac80211.

In the meantime, please be sure to try the kernels here:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=12007

They include some very recent rt2x00 driver updates and may work 
better/differently for you than the ones in the kernel you are currently 
using.  Do those kernels help?
Comment 6 Luis Felipe Marzagao 2007-07-26 11:29:33 EDT
Hello John:

Thanks a lot for the reply. I´m a little lost because of this statement from the
rt2x00 team, regarding Fedora users (in the README file):

"Although rt2x00 contains many backward compatibility fixes to ensure
that all rt2x00 components will be able to compile and run on all
systems that meet the minimal requirements, this does not work in all
situations when the Fedora kernels are being used.
The problem lies in the fact that Fedora (like most other distributions)
heavily patch their kernel for better stability and more features.
Unlike the other distributions however, Fedora does not pay attention to
compatibility for external kernel drivers. This means that compiling rt2x00
while using a Fedora kernel will result in compile errors regarding unknown
fields in structures or problems with function arguments.
For rt2x00 it is impossible to make all checks to support all Fedora kernel
releases. This means that when rt2x00 compilation is failing while using a
Fedora kernel we cannot give support for the compilation steps.
We recommend the user to complain to the Fedora developers when this problem
occurs.
If the user has managed to compile rt2x00 for a Fedora kernel we will
give support for possible problems while working with rt2x00. So the only
part we do not support is the building of rt2x00.
Please note that when you have edited the rt2x00 code to make it compile,
it is advised to state those changes in bugreports while reporting other
problems with rt2x00."

So I don´t think they´ll be helping in this issue.

Anyway, I´ll try your suggestion and report the results. Thanks again.
Comment 7 Ivo van Doorn 2007-07-26 16:51:21 EDT
Luis,

That statement came from very old versions of rt2x00,
since rt2x00 is now shipped as part of a Git repository
and the CVS versions of rt2x00 no longer have backwards
compatibility code Fedora is no longer an exception in
support.

As for your compile error, you can recompile the kernel
but make sure the mac80211 debugfs option is enabled,
or just compile rt2x00 without debugfs support...

John,

rt2x00 debugfs support depends on mac80211 debugfs because
rt2x00 creates all debugfs files within the directory
created by mac80211. That way all information for a single
device is grouped together in single location.
If this is not the desired behavior I can change it so
the files will be located somewhere else and the dependency
can be dropped.
Comment 8 Paul Simmons 2007-07-26 16:53:38 EDT
As for the "debugfs" compile error, simply edit the Config file int the rt2x00
source dir... look for "CONFIG_RT2X00_DEBUGFS=y", and change to "n".  You'll
prolly have to manually overwrite the existing modules, as the "make install"
simply puts a dir under /lib/modules/{your version}/.
Comment 9 Ivo van Doorn 2007-07-26 17:00:38 EDT
I have updated rt2x00 CVS and removed the entry about Fedora since it no 
longer applies.
Comment 10 Luis Felipe Marzagao 2007-07-26 23:50:07 EDT
Hello John, Ivo and Paul:

My bad. I had some channel problem with my wireless network. After I've changed
the channel, the default F7 modules (kernel 2.6.22.1-27) worked just fine with
my rt61 pcmcia card (including WPA). It has also worked with kernel 2.6.22.1-36.

All I had to do was copy the firmware files into /lib/firmware.

And thanks for the info about compiling without debugfs. Building was ok after that.

Note You need to log in before you can comment on or make changes to this bug.