Bug 24889 - system won't shutdown
Summary: system won't shutdown
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-24 22:48 UTC by Ben Levenson
Modified: 2014-03-17 02:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-30 22:26:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ben Levenson 2001-01-24 22:48:59 UTC
build: qa0124.0
system: Acer Altos w/ aic7xxx module
and sometimes the HP PL-450 w/ ncr53c8xx module

GUI-CDROM-Server installation

System doesn't complete shutdown:
...
Unmounting file system: umount2: Device or resource busy
umount: /usr: device is busy
                                                                                                
[FAILED]
INIT: no more processes left in this runlevel
<ctl-alt-del>
shutdown: warning: cannot open /var/run/shutdown.pid
--------------
fstab:
LABEL=/                 /                       ext2    defaults        1 1
LABEL=/boot             /boot                   ext2    defaults        1 2
LABEL=/home             /home                   ext2    defaults        1 2
/dev/cdrom              /mnt/cdrom              iso9660 noauto,owner,ro 0 0
/dev/fd0                /mnt/floppy             auto    noauto,owner    0 0
LABEL=/usr              /usr                    ext2    defaults        1 2
LABEL=/var              /var                    ext2    defaults        1 2
none                    /proc                   proc    defaults        0 0
none                    /dev/pts                devpts  gid=5,mode=620  0 0
/dev/sda9               swap                    swap    defaults        0 0
--------------

boot.log:
Jan 24 15:31:35 localhost rhnsd: rhnsd shutdown succeeded
Jan 24 15:31:36 localhost anacron: anacron shutdown succeeded
Jan 24 15:31:36 localhost rc: Stopping keytable:  succeeded
Jan 24 15:31:36 localhost xfs: xfs shutdown succeeded
Jan 24 15:31:36 localhost gpm: gpm shutdown succeeded
Jan 24 15:31:36 localhost sshd: sshd shutdown succeeded
Jan 24 15:31:36 localhost sendmail: sendmail shutdown succeeded
Jan 24 15:31:37 localhost xinetd: xinetd shutdown succeeded
Jan 24 15:31:37 localhost atd: atd shutdown succeeded
Jan 24 15:31:37 localhost crond: crond shutdown succeeded
Jan 24 15:31:37 localhost dd: 1+0 records in
Jan 24 15:31:37 localhost dd: 1+0 records out
Jan 24 15:31:37 localhost random: Saving random seed:  succeeded
Jan 24 15:31:37 localhost nfslock: rpc.statd shutdown succeeded
Jan 24 15:31:38 localhost portmap: portmap shutdown succeeded
Jan 24 15:31:39 localhost syslog: klogd shutdown succeeded

Comment 1 Jeremy Katz 2001-01-24 23:49:56 UTC
And I don't think this is related to just that system, since I've been seeing it
some on my test boxes (and cracking some of it up to AFS nuttiness, but on
reflection, it's also happened when afs never got started).

Comment 2 Bill Nottingham 2001-01-24 23:55:01 UTC
Nope, it's a problem with a) a separate /usr in combination with b) the new
initscripts.


Will be fixed in 5.59-1.

Comment 3 Ben Levenson 2001-01-30 22:25:54 UTC
verified fix in fisher


Note You need to log in before you can comment on or make changes to this bug.