This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 24894 - can't get printconf-gui-0.0-5 to work with remote lpd queue
can't get printconf-gui-0.0-5 to work with remote lpd queue
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: printtool (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-01-24 18:37 EST by dunwoody
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-02-01 16:47:36 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description dunwoody 2001-01-24 18:37:24 EST
[The bug-entry page
http://bugzilla.redhat.com/bugzilla/enter_bug.cgi?product=Red%20Hat%20Raw%20Hide
offers
the following "Component" options; I'm not sure which is most appropriate
for this bug:
    printer-config
    printtool
    prtconf
I gather that printconf /printconf-gui are intended to be replacements for
printtool, so I am filing
this bug under printtool.]

Perhaps the problem I'm reporting here is simply a result of some
mis-configuration of my system.
Nevertheless, here goes:

I installed Raw Hide 200010122 on my system, and the RPMs printtool-3.55-1
and rhs-printfilters-1.81-1 were replaced by printconf-0.0-5 and
printconf-gui-0.0-5. 
The previous contents of my /etc/printcap file were eliminated by the
printconf/printconf-gui
RPM installation scripts.  As a way of helping ensure a "fresh start", I
removed the previous
contents of /var/spool/lpd on my system.

I tried to use printconf-gui to add a remote LPD printer queue to my
/etc/printcap.local file, just
as I had previously (successfully) used printtool to add a remote LPD
printer queue to my /etc/printcap
file.  When I clicked Apply in printconf-gui, I got the following errors in
the shell window that I used to
start printconf-gui:

dunwoody2:/etc!> Stopping lpd: [FAILED]
Starting lpd: Traceback (innermost last):
  File "/usr/bin/printconf-backend", line 340, in ?
    main()
  File "/usr/bin/printconf-backend", line 333, in main
    if (swb.isNamespaceDirty('printconf') and rebuild()) or
scan_printcap("/etc/printcap"):
  File "/usr/bin/printconf-backend", line 267, in rebuild
    context = swb.writeNamespace('printconf', force = 1)
  File "/usr/lib/python1.5/site-packages/Alchemist.py", line 921, in
writeNamespace
    context = self.cascadeNamespace(name)
  File "/usr/lib/python1.5/site-packages/Alchemist.py", line 796, in
cascadeNamespace
    context_B = readBox(input_set.getChildByIndex(i))
  File "/usr/lib/python1.5/site-packages/Alchemist.py", line 623, in
readBox
    context = box.read()
  File "/usr/lib/python1.5/site-packages/FileBlackBox.py", line 155, in
read
    context = ReadContextFromFile(self.path)
  File "/usr/lib/python1.5/site-packages/FileBlackBox.py", line 24, in
ReadContextFromFile
    return Alchemist.Context(xml = xml_string)
  File "/usr/lib/python1.5/site-packages/Alchemist.py", line 226, in
__init__
    self._ctx = context_fromXML(xml)
Alchemist.ParseError: Failed to decode XML to Context
Comment 1 Crutcher Dunnavant 2001-02-01 16:26:13 EST
Hmm, something seems to be wrong with the components. A component 'printconf'
does exist, and I need to kill some of those type components ("where did they
come from?").

Hmm, its been a while since then, I've fixed so many bugs that could be causing
this. Could you examine the the directory '/etc/alchemist/namespace/printconf'
and attache a copy of the following commands to the bug report:

'ls -l', 'bzcat rpm.adl', and 'bzcat local.adl'

If local.adl has no contents, or is length zero, then youre bug is already fixed
in the current rawhide. Thanks.
Comment 2 dunwoody 2001-02-01 16:47:21 EST
crutcher@redhat.com writes:
> Hmm, its been a while since then, I've fixed so many bugs that could be
causing
>      this. Could you examine the the directory
'/etc/alchemist/namespace/printconf'
>      and attache a copy of the following commands to the bug report:
>      'ls -l', 'bzcat rpm.adl', and 'bzcat local.adl'
>      If local.adl has no contents, or is length zero, then youre bug is
already fixed
>      in the current rawhide. Thanks.

bzcat didn't work, but zcat did.  As you suggested, local.adl is length zero, so
I'll look forward to the
fix in the next rawhide release.  20010122-1 is the latest rawhide release that
is readily available to me
(via  the mirror at download.sourceforge.net), and that release still has
printconf*0.0-5, which is presumably
where the problem is.  Here are the results of the commands that you requested I
run:

--------------------------------------------------------------------------------
dunwoody2:printconf!> pwd
/etc/alchemist/namespace/printconf
dunwoody2:printconf!> ls -l
total 4
-rw-------    1 root     root            0 Feb  1 12:45 local.adl
-rw-------    1 root     root          172 Jan 22 00:14 rpm.adl
dunwoody2:printconf!> zcat rpm.adl
<?xml version="1.0"?>
<adm_context VERSION="0">
  <id NAME="rpm" SERIAL="0">
    <null/>
    <null/>
    </id>
  <datatree>
    <printconf TYPE="LIST">
      <print_queues TYPE="LIST">
        </print_queues>
      </printconf>
    </datatree>
  </adm_context>
dunwoody2:printconf!> zcat local.adl

zcat: local.adl: unexpected end of file
dunwoody2:printconf!> 
--------------------------------------------------------------------------------
Comment 3 Crutcher Dunnavant 2001-02-01 20:19:42 EST
Okay, this is definately a bug that I fixed in the alchemist.
The function WriteContextToFile was mangling some things,
and writing out zero length files.

Sorry.

I am marking this resolved in rawhide.

Note You need to log in before you can comment on or make changes to this bug.