Bug 248951 - CDT 4.0 doesn't recognize binaries create by Autotools projects
Summary: CDT 4.0 doesn't recognize binaries create by Autotools projects
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse-cdt
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnston
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-19 19:54 UTC by Jeff Johnston
Modified: 2008-02-12 20:49 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2008-02-12 20:49:22 UTC


Attachments (Terms of Use)

Description Jeff Johnston 2007-07-19 19:54:02 UTC
In the latest Autotools build that works with CDT 4.0.0, when binaries are
created by an Autotools project, they are not recognized as such by the CDT and
they do not appear in a Binaries folder under the project nor do they have a
default run action associated with them (one has to set up a run dialog entry).

The problem is traced to the fact that Autotools projects use a separate build
directory that is set up as part of the configure tool.  The CDT does not
recognize changes to the build directory made for the project and is defaulting
to the configuration name ("Build (GNU)") when looking for binaries.  This has
been confirmed by manually creating the folder and copying in an executable binary.

Comment 1 Jeff Johnston 2008-02-12 20:49:22 UTC
Problem fixed.


Note You need to log in before you can comment on or make changes to this bug.