Bug 248995 - nmap does not recognise RHEL5
nmap does not recognise RHEL5
Status: CLOSED DUPLICATE of bug 512042
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: nmap (Show other bugs)
5.0
i386 Linux
low Severity low
: ---
: ---
Assigned To: Michal Hlavinka
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 03:41 EDT by Rick van Rein
Modified: 2010-12-16 07:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-12-16 07:57:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rick van Rein 2007-07-20 03:41:11 EDT
Description of problem:

When nmap is run against localhost, it reports that it cannot determine the
fingerprint of an RHEL5 system.

Version-Release number of selected component (if applicable):

nmap-4.11-1.1

How reproducible:

On an RHEL5 system, as root, run

nmap -O localhost
  
Actual results:

Starting Nmap 4.11 ( http://www.insecure.org/nmap/ ) at 2007-07-20 07:37 GMT
Interesting ports on localhost.localdomain (127.0.0.1):
Not shown: 1679 closed ports
PORT   STATE SERVICE
25/tcp open  smtp
No exact OS matches for host (If you know what OS is running on it, see
http://www.insecure.org/cgi-bin/nmap-submit.cgi).
TCP/IP fingerprint:
SInfo(V=4.11%P=i686-redhat-linux-gnu%D=7/20%Tm=46A06641%O=25%C=1)
TSeq(Class=RI%gcd=1%SI=18C75C%IPID=Z%TS=1000HZ)
TSeq(Class=RI%gcd=1%SI=18C6ED%IPID=Z%TS=1000HZ)
T1(Resp=Y%DF=Y%W=8000%ACK=S++%Flags=AS%Ops=MNNTNW)
T2(Resp=N)
T3(Resp=Y%DF=Y%W=8000%ACK=S++%Flags=AS%Ops=MNNTNW)
T4(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
T5(Resp=Y%DF=Y%W=0%ACK=S++%Flags=AR%Ops=)
T6(Resp=Y%DF=Y%W=0%ACK=O%Flags=R%Ops=)
T7(Resp=Y%DF=Y%W=0%ACK=S++%Flags=AR%Ops=)
PU(Resp=Y%DF=N%TOS=C0%IPLEN=164%RIPTL=148%RID=E%RIPCK=E%UCK=E%ULEN=134%DAT=E)


Uptime 6.683 days (since Fri Jul 13 15:13:54 2007)

Nmap finished: 1 IP address (1 host up) scanned in 9.573 seconds


Expected results:

Something along the lines of "you are running RHEL5".

Additional info:

I could have submitted the fingerprinting information myself, but you'd need to
sync with a new package so I decided to tell you so it could be arranged
centrally by RedHat.
Comment 1 RHEL Product and Program Management 2007-12-03 15:44:16 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 2 Michal Hlavinka 2009-08-11 08:46:18 EDT
status update: I've submitted the fingerprinting information long time ago, but new nmap version gives only general information:
Running: Linux 2.6.X
OS details: Linux 2.6.9 - 2.6.26
Comment 3 RHEL Product and Program Management 2009-11-06 14:02:29 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".
Comment 4 Michal Hlavinka 2010-03-23 04:41:53 EDT
nmap is not able to recognize RHEL5, because scan results are not unique enough, but it'll be able to tell you that machine uses Linux OS with kernel 2.6.x
Comment 6 RHEL Product and Program Management 2010-08-09 15:10:28 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.
Comment 7 Michal Hlavinka 2010-12-16 07:57:34 EST
this will be fixed (improved, see comment #4) with fix for 512042

*** This bug has been marked as a duplicate of bug 512042 ***

Note You need to log in before you can comment on or make changes to this bug.