Bug 249020 - qscintilla-2.x
qscintilla-2.x
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: qscintilla (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 08:23 EDT by Neal Becker
Modified: 2008-01-31 12:27 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-31 12:27:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Neal Becker 2007-07-20 08:23:03 EDT
Description of problem:

Is the a qscintilla for qt4?
Looks like I'll need it for: UniversalIndentGUI.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Rex Dieter 2007-07-20 09:49:32 EDT
I'll look into it.
Comment 2 Rex Dieter 2007-08-29 22:05:52 EDT
Looks like we'll need a new pkg, called something like qscintilla2 for this, or
end up making qscintilla1 and qscintilla(2).  Either way, looks like we'll need
a new package review.

So, you interested in helping out?  maintaining?  comaintaining?  reviewing? :)
Comment 3 Rex Dieter 2007-08-29 22:40:28 EDT
Progress so far:
http://kdeforge.unl.edu/apt/kde-redhat/SOURCES/qscintilla2/devel/

first problem I see, similar to qwtplot3d, is that both the qt3 and qt4 versions
of qscintilla use an identical shared library name (soname + somajor). Bad. 
Means you can't really have both installed (and functional) at the same time. 
wtf were they thinking? (or maybe I totally misunderstand how it works).
Comment 4 Konstantin Ryabitsev 2007-08-30 06:16:07 EDT
I totally enjoy seeing you do all the work. :) So, if you feel like being the
only maintainer on this, that's totally fine with me.
Comment 5 Rex Dieter 2007-12-17 10:37:24 EST
Having comaintainers is always preferable.

Neal, looks like you've made some good progress recently, would you (or anyone)
be interested in submitting/maintaining qscintilla2?
Comment 6 Neal Becker 2007-12-18 09:05:41 EST
(In reply to comment #5)
> Having comaintainers is always preferable.
> 
> Neal, looks like you've made some good progress recently, would you (or 
anyone)
> be interested in submitting/maintaining qscintilla2?

I would be OK with submitting/maintaining, with the understanding that I 
really don't know anything about it and can only do simple maintenance.
Comment 7 Johan Cwiklinski 2008-01-25 21:18:39 EST
Well, I've also taken a look at it. 

Actually, results are available at :
http://odysseus.x-tnd.be/fedora/qscintilla2/qscintilla2.spec

I've take inspiration from a qscintilla2 SRPM I've found. Unfortunately, this
one was build only for QT4 ; so I cannot see how to "resolve" the library name
problem.

At this point, things seems going well, except for designer-qt3 which says
'nothing to do' at %install...

This is a draft, any comments are welcome.
Comment 8 Rex Dieter 2008-01-31 12:27:21 EST
Well, thanks for all the help, we now have qscintilla(2)/qt4 in rawhide,
replacing qscintilla v1.

Unfortunately, upstream still hasn't addressed the parallem-installability issues.

Note You need to log in before you can comment on or make changes to this bug.