Bug 249026 - libmtp: usb udev rules
libmtp: usb udev rules
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libmtp (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Linus Walleij
Fedora Extras Quality Assurance
:
: 249643 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 09:14 EDT by Harald Hoyer
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 03:50:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Hoyer 2007-07-20 09:14:17 EDT
Please change the usb udev rules from SUBSYSTEM=usb_device to SUBSYSTEM=usb.

Thank you.
Comment 1 Linus Walleij 2007-07-27 02:41:46 EDT
*** Bug 249643 has been marked as a duplicate of this bug. ***
Comment 2 Gian Paolo Mureddu 2007-07-27 03:09:46 EDT
So is this a simple udev rules edit fix or something more complex?
Comment 3 Linus Walleij 2007-07-27 10:54:58 EDT
The .spec file needs to run sed s/usb_device/usb on the libmtp.rules
file after make, but I haven't access to my cert and so cannot edit
the CVS right now (vacation) any maintainer is welcome to step in
and fix it.
Comment 4 Harald Hoyer 2007-07-30 03:50:26 EDT
changed in libmtp-0.1.5-2
Comment 5 Linus Walleij 2007-07-30 10:54:49 EDT
Thanks Harald, I also applied the first part of the patch (the
clever GOTOs) upstream, will the ATTR="zz" stuff work with old
udev too or shall upstream supply a cmdline flag for using
SYSFS="zz" or ATTR="zz" respectively?

Or should it default to using both eg:
SYSFS{idVendor}==\"%04x\", SYSFS{idProduct}==\"%04x\"
ATTR{idVendor}==\"%04x\", ATTR{idProduct}==\"%04x\"

Note You need to log in before you can comment on or make changes to this bug.