Bug 249037 - rsyslog shows newlines at the ends of messages
Summary: rsyslog shows newlines at the ends of messages
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rsyslog   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-20 14:22 UTC by Jonathan Kamens
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-30 10:17:59 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jonathan Kamens 2007-07-20 14:22:45 UTC
Some of my syslog messages just started showing "#012" at the end of them.  I
suspect this is because the programs calling the messages are sticking newlines
at the end of them.  sysklogd stripped these off but rsyslog apparently doesn't.
 I think it should, both for compatibility with sysklogd and because it makes sense.

Comment 1 Rainer Gerhards 2007-07-23 09:27:42 UTC
That's probably a config line issue. I can not directly mangle the files on
reception, because that would break compatibility with current IETF
standardization efforts. However, the templates should take care of this problem
- maybe I missed something there. Could you post your (r)syslog.conf?

Comment 2 Rainer Gerhards 2007-07-23 10:16:34 UTC
I've tackled this beast in a different way. There is a new config directive

$DropTrailingLFOnReception on|off

The default is on. If we run into trouble with IETF movements, it can always be
turned off (this is most probably a problem with syslog-sign only). The current
handling (even on) is in sync with what -syslog-protocol specifies. Will be part
of 1.17.2.

Comment 3 Peter Vrabec 2007-07-23 15:13:38 UTC
upstream version 1.17.2 was just built, could you test it please.


Note You need to log in before you can comment on or make changes to this bug.