Bug 249048 - compact flash card not detected and mounted
compact flash card not detected and mounted
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 11:26 EDT by Petr Hrasky
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 08:29:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (25.20 KB, text/plain)
2007-07-22 03:34 EDT, Petr Hrasky
no flags Details

  None (edit)
Description Petr Hrasky 2007-07-20 11:26:44 EDT
Description of problem:

compact flash card inserted in reader is not detected and mounted. It used to 
work in FC6 and still does if I use kernel from fc6 (2.6.20-1.2962.fc6)

Version-Release number of selected component (if applicable):
2.6.21-1.3228.fc7

How reproducible:
allways

Steps to Reproduce:
1. insert card
2. wait
3. wait ...
  
Actual results:

no action

Expected results:

mount card/ KDE offers to open contents in a window

Additional info:

Bus 002 Device 003: ID 05e3:0710 Genesys Logic, Inc. USB 2.0 33-in-1 Card 
Reader
Comment 1 Pete Zaitcev 2007-07-20 18:31:48 EDT
I would like to see dmesg taken after the insertion.
Comment 2 Petr Hrasky 2007-07-21 14:17:15 EDT
this is shortly after boot:

audit(1185041526.584:2): audit_pid=2017 old=0 by auid=4294967295
Bluetooth: Core ver 2.11
NET: Registered protocol family 31
Bluetooth: HCI device and connection manager initialized
Bluetooth: HCI socket layer initialized
Bluetooth: L2CAP ver 2.8
Bluetooth: L2CAP socket layer initialized
Bluetooth: RFCOMM socket layer initialized
Bluetooth: RFCOMM TTY layer initialized
Bluetooth: RFCOMM ver 1.8
Bluetooth: HIDP (Human Interface Emulation) ver 1.2
i2c_adapter i2c-2: SMBus Quick command not supported, can't probe for chips
w83627ehf: unsupported chip ID: 0xffff
eth0: no IPv6 routers present
NET: Registered protocol family 4
NET: Registered protocol family 5


so nothing to work on I guess.

Anyway since then I upgraded to kernel-2.6.22.1-27.fc7 and it work well again.
Comment 3 Petr Hrasky 2007-07-21 14:29:20 EDT
And this is what I get in 2.6.22.1, dmesg, messages

NET: Registered protocol family 5
sd 6:0:0:0: [sdc] 31488 512-byte hardware sectors (16 MB)
sd 6:0:0:0: [sdc] Write Protect is off
sd 6:0:0:0: [sdc] Mode Sense: 02 00 00 00
sd 6:0:0:0: [sdc] Assuming drive cache: write through
sd 6:0:0:0: [sdc] 31488 512-byte hardware sectors (16 MB)
sd 6:0:0:0: [sdc] Write Protect is off
sd 6:0:0:0: [sdc] Mode Sense: 02 00 00 00
sd 6:0:0:0: [sdc] Assuming drive cache: write through
 sdc: sdc1




Jul 21 20:27:02 hal9000 kernel: sd 6:0:0:0: [sdc] 31488 512-byte hardware
sectors (16 MB)
Jul 21 20:27:02 hal9000 kernel: sd 6:0:0:0: [sdc] Write Protect is off
Jul 21 20:27:02 hal9000 kernel: sd 6:0:0:0: [sdc] Assuming drive cache: write
through
Jul 21 20:27:02 hal9000 kernel: sd 6:0:0:0: [sdc] 31488 512-byte hardware
sectors (16 MB)
Jul 21 20:27:02 hal9000 kernel: sd 6:0:0:0: [sdc] Write Protect is off
Jul 21 20:27:02 hal9000 kernel: sd 6:0:0:0: [sdc] Assuming drive cache: write
through
Jul 21 20:27:02 hal9000 kernel:  sdc: sdc1
Jul 21 20:27:15 hal9000 automount[2373]: lookup_mount: >> /usr/sbin/showmount:
can't get address for .directory
Jul 21 20:27:16 hal9000 hald: mounted /dev/sdc1 on behalf of uid 500


Comment 4 Pete Zaitcev 2007-07-21 17:19:06 EDT
Please attach the COMPLETE dmesg. I'd like to see if we enabled ub by accident.
Please do not drop it into comments box.
Comment 5 Petr Hrasky 2007-07-22 03:34:37 EDT
Created attachment 159736 [details]
dmesg output

output from dmesg after boot and inserting of a cf card
Comment 6 Christopher Brown 2007-09-20 06:48:11 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris
Comment 7 Petr Hrasky 2007-09-20 08:01:35 EDT
Latest 2.6.22.x kernels are working fine. I thought no new information is needed
after I attached full dmesg output. Feel free to close the bug. However I have
no idea what went wrong with the particular kernel release.
Comment 8 Christopher Brown 2007-09-20 08:29:22 EDT
I can't shed any light on it - I also had the same problem with previous
kernels. Please re-open if you experience a regression of course. Thanks for the
update.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.