Bug 249070 - Invalid desktop file
Summary: Invalid desktop file
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: chmsee (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Yijun Yuan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-20 18:36 UTC by Jesse Keating
Modified: 2013-01-10 02:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-31 02:24:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jesse Keating 2007-07-20 18:36:41 UTC
Package fails to build due to:

+ desktop-file-install --vendor fedora --delete-original --dir
/var/tmp/chmsee-1.0.0-0.20.beta2.fc8-root-kojibuilder/usr/share/applications
/var/tmp/chmsee-1.0.0-0.20.beta2.fc8-root-kojibuilder/usr/share/applications/chmsee.desktop
/var/tmp/chmsee-1.0.0-0.20.beta2.fc8-root-kojibuilder/usr/share/applications/fedora-chmsee.desktop:
error: value "1.0.0" for key "Version" in group "Desktop Entry" is not a known
version
desktop-file-install created an invalid desktop file!
error: Bad exit status from /var/tmp/rpm-tmp.94576 (%install)

See http://koji.fedoraproject.org/koji/getfile?taskID=71871&name=build.log for
complete log.  This needs to be rebuilt for firefox, preferably before the Test1
freeze next week.

Comment 1 Yijun Yuan 2007-07-21 01:30:03 UTC
Thank you for the reminder.. I built it several times and each time the x86_64
build is break because cannot find firefox-devel 2.0.0.5, so I didn't notice
ppc64 problem.. I'll try to fix it ASAP.

Is there anything important about desktop-file-install in ppc64? Or is there
anything about "Version" usage change in desktop file?

Comment 2 Yijun Yuan 2007-07-21 01:39:41 UTC
/me reading 
http://fedoraproject.org/wiki/Packaging/Guidelines#desktop
and
http://standards.freedesktop.org/desktop-entry-spec/latest/ar01s05.html

It should be 1.0 or absent, instead of 1.0.0. I'll change the patch and request
for another build.

Comment 3 Yijun Yuan 2007-08-31 02:24:54 UTC
I like the new bugzilla. Fast. Reminders. :)



Note You need to log in before you can comment on or make changes to this bug.