Bug 249078 - CRC errors with dmraid on adaptec aic94xx
CRC errors with dmraid on adaptec aic94xx
Status: CLOSED CANTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: dmraid (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Heinz Mauelshagen
Corey Marthaler
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-20 15:12 EDT by Bryn M. Reeves
Modified: 2011-01-24 16:48 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-12-10 13:10:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
ddf1 metadata dump from aic94xx (4.25 KB, text/plain)
2007-07-20 15:12 EDT, Bryn M. Reeves
no flags Details
raw ddf1.dat (2.00 MB, application/octet-stream)
2007-07-20 15:14 EDT, Bryn M. Reeves
no flags Details

  None (edit)
Description Bryn M. Reeves 2007-07-20 15:12:16 EDT
Description of problem:
Attempting to install to a dmraid volume on an adaptec aic94xx card spits CRC
errors:
ddf1: virtual drives with CRC F4235BD2, expected B27A2FEA on /dev/sda
ddf1: physical drives with CRC 833C5EC2, expected 132A55D9 on /dev/sda

The same thing is reported to occur with adaptec's own open driver suggesting
they may not be completely adhering to the ddf1 spec.

Version-Release number of selected component (if applicable):
dmraid-1.0.0.rc13-2.el5

How reproducible:
100%

Steps to Reproduce:
1. Create an array in the BIOS management utility
2. Boot RHEL5 install media & attempt an install onto the dmraid device

  
Actual results:
Above CRC errors appear on console

Expected results:
Install completes succesfully

Additional info:
Will attach metadata dumps from the devices
Comment 1 Bryn M. Reeves 2007-07-20 15:12:19 EDT
Created attachment 159676 [details]
ddf1 metadata dump from aic94xx
Comment 2 Bryn M. Reeves 2007-07-20 15:14:40 EDT
Created attachment 159677 [details]
raw ddf1.dat
Comment 3 Bryn M. Reeves 2007-07-20 15:15:27 EDT
Comment on attachment 159676 [details]
ddf1 metadata dump from aic94xx

fixing content type - this is no patch!
Comment 5 Heinz Mauelshagen 2007-07-23 06:40:06 EDT
Bryn,

no, that's fine as the necessary input for now.

The problem is, that the crc cwalgorithm *was* not fully clear and still isn't.
If I don't get my hands on a detailed crc spec for DDF1 *including* any Adaptec
quirks, there's not much I can do about it rather than wasting time on
reengineering.
Comment 12 RHEL Product and Program Management 2007-10-19 16:27:27 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 15 Issue Tracker 2008-02-19 09:51:50 EST
changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REJECTED                    |CLOSED




------- Additional Comments From rosalesa@us.ibm.com (prefers email at
rosalesa@austin.ibm.com)  2008-02-18 20:16 EDT -------
Red Hat,
Thanks for your support on this defect.
IBM is closing this bug as "Will Not Fix."
-thanks. 


This event sent from IssueTracker by jkachuck 
 issue 123310
Comment 17 RHEL Product and Program Management 2008-06-02 16:35:26 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 18 RHEL Product and Program Management 2008-10-27 14:21:54 EDT
This request was previously evaluated by Red Hat Product Management
for inclusion in the current Red Hat Enterprise Linux release, but
Red Hat was unable to resolve it in time.  This request will be
reviewed for a future Red Hat Enterprise Linux release.

Note You need to log in before you can comment on or make changes to this bug.