Bug 249163 - mkinitrd silently ignores missing modules
mkinitrd silently ignores missing modules
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: mkinitrd (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
:
: 226709 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-21 15:24 EDT by Eric Lee
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-11 16:45:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Eric Lee 2007-07-21 15:24:09 EDT
Description of problem
/sbin/mkinitrd silently ignores bad module names

Version-Release number of selected component (if applicable):
mkinitrd-6.0.9-7.1

How reproducible:
100%

Steps to Reproduce:
1. execute: mkinitrd --with=fake-module /tmp/junk `uname -r`
  
Actual results:
new /tmp/junk is generated with no complaint about missing module

Expected results:
should fail with message:
No module fake-module found for kernel 2.6.21-1.3228.fc7, aborting.

Additional info:

/sbin/mkinitrd: LINE 307: double-quotes missing around variable:

 if [ ! -f $fmPath ]; then

fix:

 if [ ! -f "$fmPath" ]; then
Comment 1 Peter Jones 2007-09-14 15:33:17 EDT
*** Bug 226709 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.