Bug 249179 - With 2.6.22.1-27.fc7 pppoe does not work correct
With 2.6.22.1-27.fc7 pppoe does not work correct
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-22 04:25 EDT by Michael Weidner
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.22.5-76.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-20 09:05:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Weidner 2007-07-22 04:25:51 EDT
After update to Kernel 2.6.22.1-27.fc7 form 2.6.21-1.3228.fc7 pppoe does not
work correct. 

I have 2 the-Devices (eth0 and eth1) bridged together to a bridging device br0.
eth0 is a 8139too and eth1 a via-rhine. pppoe uses the br0-device as eth-device.

With 2.6.21-1.3228.fc7 everything works fine (ADSL connects and works as
wanted), but with 2.6.22.1-27.fc7 pppoe connects to the provider (login ok, PAP
ok, ip assign ok, assign default gateway ok, route ok), but if I try transmit or
receive data over ppp0 there is always a error message in /var/log/messages and
no data can be received (i.e. if I try to browse a web page).

This is the error in /var/log/messages (it appears very often):
pppoe[3484]: Bogus PPPoE length field (48)

Back to 2.6.21-1.3228.fc7 everything is ok.

/etc/sysconfig/network-scripts/ifcfg-ppp0:
ONBOOT=yes
USERCTL=no
IPV6INIT=no
PEERDNS=no
TYPE=xDSL
DEVICE=ppp0
BOOTPROTO=dialup
PIDFILE=/var/run/pppoe-adsl.pid
FIREWALL=NONE
PING=.
PPPOE_TIMEOUT=80
LCP_FAILURE=3
LCP_INTERVAL=20
CLAMPMSS=1452
CONNECT_POLL=6
CONNECT_TIMEOUT=0
RETRYTIMEOUT=5
PERSIST=yes
SYNCHRONOUS=no
DEFROUTE=yes
USER=xxx
ETH=br0
PROVIDER=xxx
DEMAND=no
MTU=1492
MRU=1492

/etc/sysconfig/network-scripts/ifcfg-eth0:
# Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+
DEVICE=eth0
ONBOOT=yes
BOOTPROTO=none
HWADDR=xx:xx:xx:xx:xx:xx
BRIDGE=br0
TYPE=Ethernet

/etc/sysconfig/network-scripts/ifcfg-eth1:
# VIA Technologies, Inc. VT6102 [Rhine-II]
DEVICE=eth1
ONBOOT=yes
BOOTPROTO=none
HWADDR=xx:xx:xx:xx:xx:xx
BRIDGE="br0"
TYPE=Ethernet

/etc/sysconfig/network-scripts/ifcfg-br0:
DEVICE=br0
ONBOOT=yes
TYPE=Bridge
IPADDR=192.168.0.99
NETMASK=255.255.255.0
NETWORK=192.168.0.0
BROADCAST=192.168.0.255
IPV6INIT=no
BOOTPROTO=none
USERCTL=no
PEERDNS=no
STP=on
NOZEROCONF=no


How reproducible:
Every time booting with 2.6.22.1-27.fc7.

Steps to Reproduce:
Boot the system with 2.6.22.1-27.fc7.
Comment 1 Chuck Ebbert 2007-07-23 14:57:14 EDT
Can you try it without the bridge, in other words run pppoe directly
over eth0 or eth1? This could help narrow down the problem.
Comment 2 Michael Weidner 2007-07-24 12:54:25 EDT
I have tried it direktly over eth0 (only eth0 activated), seems to work without
bridging (no errors in /var/log/message and browsing the web is ok)

The config of eth0 was:

/etc/sysconfig/network-scripts/ifcfg-eth0:
# VIA Technologies, Inc. VT6102 [Rhine-II]
DEVICE=eth0
ONBOOT=yes
TYPE=Ethernet
IPADDR=192.168.0.99
NETMASK=255.255.255.0
IPV6INIT=no
BOOTPROTO=none
USERCTL=no
PEERDNS=no
NOZEROCONF=no

ppp0 was the same configuartion as above, only change "ETH=eth0"

Sorry, I have to switch back because I need the bridge for my LAN to work.
Comment 3 Christopher Brown 2007-09-20 06:59:06 EDT
Hello Michael,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.

Cheers
Chris

Note You need to log in before you can comment on or make changes to this bug.