Bug 24925 - (7.1-beta3 tree) traceback
Summary: (7.1-beta3 tree) traceback
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
: 24936 24947 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-01-25 13:43 UTC by Tim Waugh
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-25 23:20:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
This works around it, but is probably wrong. (759 bytes, patch)
2001-01-25 13:44 UTC, Tim Waugh
no flags Details | Diff

Description Tim Waugh 2001-01-25 13:43:45 UTC
Got this traceback with an FTP install:

Traceback (innermost last):
  File "/usr/bin/anaconda.real", line 500, in ?
    extraModules = extraModules, pcicController = pcicController)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 557, in
__init__
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1275, in
setClass+File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 309,
in
+setRuntimeLanguage
KeyError: English (US)
install exited abnormally

Comment 1 Tim Waugh 2001-01-25 13:44:39 UTC
Created attachment 8230 [details]
This works around it, but is probably wrong.

Comment 2 Tim Waugh 2001-01-25 13:47:56 UTC
Here's how I ran into it:

Non-anonymous FTP install
boot: linux expert
System has ISA NE2000.

When asked if I wanted to add any special device drivers, I said 'yes', and
'yes' to whether I have a driver disk, and 'Network', then 'Back' and 'Back' (to
work around bug 24842).

Comment 3 Brock Organ 2001-01-25 16:22:01 UTC
*** Bug 24936 has been marked as a duplicate of this bug. ***

Comment 4 Elliot Lee 2001-01-25 17:53:51 UTC
I can confirm seeing this behaviour - did an upgrade with bootnet.img from an
NFS tree, received the error with both text and graphical installs shortly after
getting into stage 2.

Comment 5 Ben Levenson 2001-01-25 20:43:09 UTC
Get the same traceback when installing on ia64 (Big Sur-UP):
English: NFS-GUI, HTTP-TUI, Hard drive-GUI/TUI

Comment 6 Glen Foster 2001-01-25 20:47:31 UTC
*** Bug 24947 has been marked as a duplicate of this bug. ***

Comment 7 Michael Fulbright 2001-01-25 22:14:20 UTC
This is fixed in the latest tree we've made internally. Should show up for final
beta 3 tree when its built (on ia32, dont know about ia64).

Comment 8 Brock Organ 2001-01-25 23:20:49 UTC
verified fix in qa0125.0 test tree ...


Note You need to log in before you can comment on or make changes to this bug.