Bug 249360 - Include default cpulimit command in limits.d/realtime.conf as comment
Include default cpulimit command in limits.d/realtime.conf as comment
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: distribution (Show other bugs)
1.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Luis Claudio R. Goncalves
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-23 18:06 EDT by Darren Hart
Modified: 2008-02-27 14:54 EST (History)
1 user (show)

See Also:
Fixed In Version: pam-0.99.6.2-3.26.el5, rt-setup-1.0-1.el5rt
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-02 17:00:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Darren Hart 2007-07-23 18:06:40 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.5) Gecko/20061201 Firefox/2.0.0.5 (Ubuntu-feisty)

Description of problem:
Opening a new bug on this per Tim Burke's request.

BUG 232700 adds support for a limits.d directory.  Comment 16 mentioned removing the cpu limit line from the realtime.conf file because unlimited was the default setting.  I'd prefer to see this commented out and left as reference since this setting is often edited by real-time application developers ton development sytems to prevent runaway tasks from effectively taking down the system.  Leaving this confg line in as a comment would save many developers the hassle of having to look up the syntax.

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
N/A

Actual Results:


Expected Results:


Additional info:
Comment 1 Tomas Mraz 2007-07-23 18:30:35 EDT
Actually it will not be part of RHEL-5.1, it will be part of the RHEL RT setup.


*** This bug has been marked as a duplicate of 249318 ***
Comment 2 Tim Burke 2007-07-24 11:25:26 EDT
Changed release from standard RHEL to RHEL-RT. Reopening and reassiging to Luis
as this is in the separate from PAM package where we will be shipping the
realtime specific limits.conf file.
Comment 3 Luis Claudio R. Goncalves 2007-08-02 10:23:45 EDT
Done. Will be in the rt repository really soon.
Comment 4 Luis Claudio R. Goncalves 2007-08-02 17:00:52 EDT
The packages pam-0.99.6.2-3.26.el5 and rt-setup-1.0-1.el5rt, that close this
bug, are already in the rt partner repository. A simple

yum install rt-setup

is enough to install both packages.

Note You need to log in before you can comment on or make changes to this bug.