Bug 249369 - Pup (package updater) crashes safely with insufficient information
Pup (package updater) crashes safely with insufficient information
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
: 318241 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-23 22:13 EDT by Leslie Satenstein
Modified: 2014-01-21 17:59 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 17:48:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
print screen of the pup execution that failed. (14.82 KB, image/png)
2007-07-23 22:13 EDT, Leslie Satenstein
no flags Details

  None (edit)
Description Leslie Satenstein 2007-07-23 22:13:52 EDT
Description of problem:

On a shared machine one admin person added a new repository to yum.repos.d and
forgot to tell the other admin about the change.  The repository was for adobe.
The parameter file therein was marked enable and regretfully, the url in the
file was not reachable.

When pup executed, it failed because of the adobe repro. Pup only reported that
QUOTE "Unable to retrieve software information. This could be by not having a
network connection."

Since this problem occurred on a Friday, and it persisted until Monday, when the
problem was detected, the thought was that the Fedora site was down for the weekend.

Can you please beef up the error message to add the repro file id which caused
the error?  This would be a good product enhancement.


Version-Release number of selected component (if applicable):


How reproducible:

as described above.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Leslie Satenstein 2007-07-23 22:13:52 EDT
Created attachment 159826 [details]
print screen of the pup execution that failed.
Comment 2 Jeremy Katz 2007-07-24 17:48:09 EDT
Fixed in CVS, will be in 1.3.10
Comment 3 Jeremy Katz 2007-10-05 10:18:15 EDT
*** Bug 318241 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.