Bug 249410 - Picture folder does not work.
Picture folder does not work.
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gnome-screensaver (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Ray Strode [halfline]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 11:02 EDT by Steve
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 08:55:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
gnome-screensaver-2.19.1.1-2.fc8 (1.91 MB, text/plain)
2007-07-25 03:36 EDT, Steve
no flags Details
gnome-screensaver-2.18.2-2.fc7 (2.29 MB, text/plain)
2007-07-25 04:46 EDT, Steve
no flags Details
update 27. juli '07 (2.03 KB, text/plain)
2007-07-30 06:48 EDT, Steve
no flags Details

  None (edit)
Description Steve 2007-07-24 11:02:54 EDT
Description of problem:
Picture folder does not work, even if there is an ati or nvidia card, selinux
enabled or disabled or pictures are inside or a symlink to pictures.

Version-Release number of selected component (if applicable):
gnome-screensaver-2.18.2-2.fc7

How reproducible:
Try to use "Picture folder" in gnome-screensaver.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
Should be working

Additional info:
Comment 1 Matthias Clasen 2007-07-24 12:18:37 EDT
Do you have a binary named /usr/bin/slideshow ? If yes, that may be the cause of
the problem, and a possible fix is to edit

/usr/share/applications/screensaver/personal-slideshow.desktop 
and replace the line 

TryExec=slideshow

by

TryExec=/usr/libexec/gnome-screensaver/slideshow

Can you try that and report if it helps ?
Comment 2 Steve 2007-07-24 14:50:18 EDT
No, i don't have slideshow in my system.
Comment 3 Steve 2007-07-24 14:55:18 EDT
If i execute /usr/libexec/gnome-screensaver/slideshow, there comes a black
window and the cpu goe's high.
Comment 4 Ray Strode [halfline] 2007-07-24 15:13:52 EDT
how many pictures do you have in ~/Pictures ? How big are they on average?
Comment 5 Steve 2007-07-24 17:32:37 EDT
It doesn't matter if they are 20 pictures or a symlink with 10'000 pictures,
there is just no screen saver.
Comment 6 Steve 2007-07-24 17:36:01 EDT
Before, in rawhide, with a symlink with about 10'000 pictures in there, it was
working.
Comment 7 Ray Strode [halfline] 2007-07-24 21:35:11 EDT
can you run

strace -s512 -f -o slideshow.log /usr/libexec/gnome-screensaver/slideshow

and attach slideshow.log 

?
Comment 8 Steve 2007-07-25 03:32:08 EDT
I can not send the log of my machine because it contains too much personal
information. it it reading my whole archive with more then 500gb data. i send
you the log from rawhide which is also not working. hope it helps.
Comment 9 Steve 2007-07-25 03:36:26 EDT
Created attachment 159905 [details]
gnome-screensaver-2.19.1.1-2.fc8
Comment 10 Steve 2007-07-25 04:46:23 EDT
Created attachment 159907 [details]
gnome-screensaver-2.18.2-2.fc7

Here is a log file from a fedora 7 machine which is not scanning personal
information and is also not working.
Comment 11 Steve 2007-07-30 06:48:12 EDT
Created attachment 160233 [details]
update 27. juli '07

(In reply to comment #9)
> Created an attachment (id=159905) [edit]
> gnome-screensaver-2.19.1.1-2.fc8
> 

The screensaver from rawhide does work since the last update. i don't know why
or from which package...
Comment 12 Steve 2007-08-17 08:36:29 EDT
has is something to do with WINE? 

when i execute:

$ strace -s512 -f -o slideshow.log /usr/libexec/gnome-screensaver/slideshow

after two minutes, the terminal output looks like this and the size of the
slideshow.log is about 200mb:

** (slideshow:5612): WARNING **: Could not open directory: /home/sysop/.dbus

** (slideshow:5612): WARNING **: Could not open directory:
/home/sysop/.wine/dosdevices/c:/windows/profiles/sysop/My Music/.dbus

** (slideshow:5612): WARNING **: Could not open directory:
/home/sysop/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My Music/.dbus

** (slideshow:5612): WARNING **: Could not open directory:
/home/sysop/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My Music/.dbus

** (slideshow:5612): WARNING **: Could not open directory:
/home/sysop/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My Music/.dbus

** (slideshow:5612): WARNING **: Could not open directory:
/home/sysop/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My Music/.dbus

** (slideshow:5612): WARNING **: Could not open directory:
/home/sysop/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My
Music/.wine/dosdevices/c:/windows/profiles/sysop/My Music/.dbus
Comment 13 Steve 2007-10-11 03:53:29 EDT
I deinstalled wine and the problem still exists.
I reinstalled gnome-screensaver and the problem still exists.
I disabled selinux and the problem still exists.
I changed some permissions and the errors was gone, but still no pictures and
the cpu is still of 100%.

Note You need to log in before you can comment on or make changes to this bug.