Bug 249473 - File magic file wrongly identifies text file as MPEG-4 LO-EP audio stream
File magic file wrongly identifies text file as MPEG-4 LO-EP audio stream
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: file (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Tomas Smetana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-24 17:16 EDT by Rodrigo Barbosa
Modified: 2009-01-20 17:02 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 17:02:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Sample file to reproduce the bug (23 bytes, application/octet-stream)
2007-07-24 17:16 EDT, Rodrigo Barbosa
no flags Details

  None (edit)
Description Rodrigo Barbosa 2007-07-24 17:16:49 EDT
Description of problem:
File will identify any text file starting with "Má" (iso-8859-1) as a MPEG-4
LO-EP audio stream. Since that character combination is fairly common on several
languages, this can cause serious problems.

Version-Release number of selected component (if applicable):
file-4.17-9

How reproducible:
Attached file

Steps to Reproduce:
1. $ file magic-bug-sample.txt

  
Actual results:
magic-bug-sample.txt: MPEG-4 LO-EP audio stream

Expected results:
magic-bug-sample.txt: ISO-8859 text

Additional info:
Comment 1 Rodrigo Barbosa 2007-07-24 17:16:49 EDT
Created attachment 159888 [details]
Sample file to reproduce the bug
Comment 2 Tomas Smetana 2008-02-01 04:43:16 EST
You're right.  I think we should rather remove support for the MPEG LO-EP format
-- it's very rare and if it really can be determined by the first two bytes
only, it makes more sense to report the text files correctly.
Comment 3 Rodrigo Barbosa 2008-02-01 11:10:19 EST
That is pretty much what I have been doing on my server. Removing the support
for that format and recompiling the mgc file.
Interesting too is the fact this only happens with the regular (non-mime) file
detection. The mime-type detection shows the file correctly, which points to
further problems, since there is a discrepancy between the regular and the
mime-type magic files.
Comment 4 RHEL Product and Program Management 2008-06-04 18:49:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 9 errata-xmlrpc 2009-01-20 17:02:51 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0208.html

Note You need to log in before you can comment on or make changes to this bug.