Bug 249520 - ypbind initscript does not write error message when DOMAINNAME cannot be set
Summary: ypbind initscript does not write error message when DOMAINNAME cannot be set
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: ypbind   
(Show other bugs)
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Vitezslav Crhonek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-07-25 11:30 UTC by Karel Volný
Modified: 2009-01-20 21:48 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 21:48:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (381 bytes, patch)
2008-04-14 13:19 UTC, Vitezslav Crhonek
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0182 normal SHIPPED_LIVE ypbind bug fix update 2009-01-20 16:05:49 UTC

Description Karel Volný 2007-07-25 11:30:36 UTC
Description of problem:
The initscript for ypbind checks whether DOMAINNAME is set and has other value 
than "(none)". If not, it checks whether NISDOMAIN is not empty and sets 
DOMAINNAME to NISDOMAIN value in that case. Otherwise it will silently quit 
with exit code 1, leaving user no clue what has failed.

For troubleshooting purposes, failures should be logged, as suggested in bug 
#220646.

Comment 1 RHEL Product and Program Management 2007-07-25 15:14:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 4 Tom Coughlan 2007-11-13 20:39:59 UTC
ypbind is not an approved package for 5.2. I'll set "fast". Steve, if this is
not feasible for FasTrack, then close or defer it. 

Comment 5 Suzanne Yeghiayan 2008-02-01 19:28:55 UTC
Since this bugzilla was filed against pre-RHEL 5.1 and was not addressed in 5.2
Beta via FasTrack, moved to 5.3 FasTrack.

Comment 6 Vitezslav Crhonek 2008-04-14 13:19:28 UTC
Created attachment 302333 [details]
proposed patch

Comment 8 RHEL Product and Program Management 2008-06-02 20:35:11 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 13 errata-xmlrpc 2009-01-20 21:48:25 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0182.html


Note You need to log in before you can comment on or make changes to this bug.