This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 249557 - bring consistency to intr mount option for all nfs flavors
bring consistency to intr mount option for all nfs flavors
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeff Layton
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 10:55 EDT by Jeff Layton
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-14 07:06:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
upstream patch -- make mount default to nointr (337 bytes, patch)
2007-07-25 11:05 EDT, Jeff Layton
no flags Details | Diff
patch -- make intr the default for v2/3 and fix manpage (1.25 KB, patch)
2007-07-25 15:18 EDT, Jeff Layton
no flags Details | Diff
patch -- make string-based mount options default to "intr" (786 bytes, patch)
2007-07-25 15:19 EDT, Jeff Layton
no flags Details | Diff

  None (edit)
Description Jeff Layton 2007-07-25 10:55:10 EDT
util-linux defaults to setting the "intr" option for NFSv4 mounts. It should
default to "nointr".

This looks like it might also be an issue with later RHEL/Fedora releases and
upstream, but I need to confirm.
Comment 1 Jeff Layton 2007-07-25 11:05:31 EDT
Created attachment 159934 [details]
upstream patch -- make mount default to nointr

Patch I plan to send upstream once I test it. It should make mount.nfs4 default
to "nointr".
Comment 9 Jeff Layton 2007-07-25 15:17:08 EDT
Fixing tagline. I'm morphing this ticket to track some patches that I've sent
upstream to (hopefully) make intr the default for all NFS flavors...
Comment 10 Jeff Layton 2007-07-25 15:18:40 EDT
Created attachment 159973 [details]
patch -- make intr the default for v2/3 and fix manpage

This patch I sent upstream. It makes "intr" the default for v2/3 and fixes the
manpage accordingly.
Comment 11 Jeff Layton 2007-07-25 15:19:42 EDT
Created attachment 159974 [details]
patch -- make string-based mount options default to "intr"

This patch makes "intr" the default when using string-based mount options on
the latest upstream kernels.
Comment 12 Jeff Layton 2007-07-30 09:09:07 EDT
Upstream comments seem to indicate that defaulting to "intr" might be
problematic. If a close call is interrupted during the sync, then the close can
return EINTR without actually syncing the file out to the server. The file is
still closed, however and locks are released. This can lead to data corruption.
There was a bit of discussion around ways to avoid this, but for the time being
"nointr" should probably be the default.

It looks like the string-based mount options already are going to default to
nointr for nfs4. The question here is whether we want to fix struct based mount
options to do the same. Since that will hopefully just go away eventually, it
may be best to just not worry about it.
Comment 13 Jeff Layton 2007-08-14 07:06:00 EDT
Chuck Lever's doing a number of mount.nfs cleanups upstream and seems to be
looking at this as well. I'll leave this in his hands for now. It's unlikely
that we'd want to change RHEL's behavior anyway...

Note You need to log in before you can comment on or make changes to this bug.