Bug 249558 - [PATCH]: use instance-less AFS service tickets
[PATCH]: use instance-less AFS service tickets
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam_krb5 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On: 231137
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 10:55 EDT by Nalin Dahyabhai
Modified: 2009-01-20 16:19 EST (History)
2 users (show)

See Also:
Fixed In Version: 2.2.14-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-20 16:19:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2007-07-25 10:55:53 EDT
+++ This bug was initially created as a clone of Bug #231137 +++

We see several unsuccessful attempts for AFS service tickets on our KDC per
login, and are trying to reduce these. Our AFS tickets are of the form
"afs@REALM.COM" (i.e. no AFS cell as the instance).

The patch adds a new private option "nullafs" that tells pam_krb5 to not bother
looking for fully-instantiated tickets of the form afs/cell@REALM, and instead
use  afs@REALM directly (otherwise it would fall back to these anyway).
Likewise, afs5log gets an option "-n" that does the same thing.

The attached patch is against 2.2.8-1 (since that is what we use currently), I
can reflow this gainst some different version if this increases the likelihood
of being applied.

-- Additional comment from jan.iven@cern.ch on 2007-03-06 09:24 EST --
Created an attachment (id=149336)
patch to add "nullafs" option, "-n" for afs5log


-- Additional comment from pm-rhel@redhat.com on 2007-07-06 14:05 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 1 RHEL Product and Program Management 2007-12-03 15:44:34 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 2 RHEL Product and Program Management 2008-06-02 16:35:01 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 7 errata-xmlrpc 2009-01-20 16:19:41 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0135.html

Note You need to log in before you can comment on or make changes to this bug.