Bug 249559 - [PATCH]: use 2b-style AFS tickets even if KerberosIV support is enabled
[PATCH]: use 2b-style AFS tickets even if KerberosIV support is enabled
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pam_krb5 (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On: 231136
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 10:57 EDT by Nalin Dahyabhai
Modified: 2008-10-17 13:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-17 13:01:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nalin Dahyabhai 2007-07-25 10:57:56 EDT
+++ This bug was initially created as a clone of Bug #231136 +++

We see several unsuccessful attempts for AFS service tickets on our KDC per
login, and are trying to reduce these. Our AFS tickets are of the form
"afs@REALM.COM" (i.e. no AFS cell as the instance).

The patch adds a new private option "prefer_2b":

Even with Kerberos IV-support enabled, still try to use the 2b-style
service tickets based on KerberosV instead of using the
KerberosIV-based ones. 

This is the equivalent of giving "-5" to the afs5log command. The effect is to
reduce the number of failed attempts from 9 to 3 (different encoding types are
tried for realm-instance tickets, patch for that follows as well).

The patch is against 2.2.8, I can rework it against other versions if required.

Best regards

-- Additional comment from jan.iven@cern.ch on 2007-03-06 09:11 EST --
Created an attachment (id=149335)
new option "prefer_2b"


-- Additional comment from pm-rhel@redhat.com on 2007-07-06 14:06 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 1 RHEL Product and Program Management 2007-12-03 15:44:36 EST
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release.  This request will
be reviewed for a future Red Hat Enterprise Linux release.
Comment 2 Nalin Dahyabhai 2008-02-15 15:49:05 EST
When rxk5 becomes available, we're going to have three different ways for
formatting tokens, and at that point I don't think boolean options are going to
provide enough flexibility to set the preferred order in which the various
methods should be tried.  I'm working on this in the development branch; leaving
this in ASSIGNED until that gets shaken out.
Comment 3 RHEL Product and Program Management 2008-06-02 16:34:57 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Nalin Dahyabhai 2008-09-12 11:59:28 EDT
It's worked out in 2.3, though the changes involved (token_strategy) were more extensive than I'm comfortable with backporting to 2.2.  Moving this to wont-fix because this is a RHEL 5 bug rather than a RHEL-in-general bug, and the next major release will pull in 2.3 or later.

Note You need to log in before you can comment on or make changes to this bug.