Bug 249569 - 'ulimit -H -v' does not limit virtual set size
'ulimit -H -v' does not limit virtual set size
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-07-25 11:37 EDT by Bill C. Riemers
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-31 12:27:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill C. Riemers 2007-07-25 11:37:05 EDT
+++ This bug was initially created as a clone of Bug #249565 +++

+++ This bug was initially created as a clone of Bug #220657 +++

Escalated to Bugzilla from IssueTracker

-- Additional comment from twaugh@redhat.com on 2007-04-23 06:47 EST --
*** Bug 237210 has been marked as a duplicate of this bug. ***

-- Additional comment from pm-rhel@redhat.com on 2007-05-09 04:29 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

-- Additional comment from twaugh@redhat.com on 2007-05-15 05:42 EST --
*** Bug 237212 has been marked as a duplicate of this bug. ***

-- Additional comment from tao@redhat.com on 2007-06-14 13:00 EST --
Closing per Eric's comments on 6/14/ phone call.

Internal Status set to 'Resolved'
Status set to: Closed by Client
Resolution set to: 'RHEL 4.6'
Ticket type set to: 'Problem'

This event sent from IssueTracker by cww 
 issue 108993

-- Additional comment from twaugh@redhat.com on 2007-07-11 10:24 EST --
*** Bug 247787 has been marked as a duplicate of this bug. ***

-- Additional comment from briemers@redhat.com on 2007-07-20 12:20 EST --
This problem also effects RHEL5, and Fedora 7.  See bug #249051 for more
information.

Bill
Comment 1 Bill C. Riemers 2007-07-25 11:38:29 EDT
Interesting enough, ulimit -v does work for zsh.
Comment 2 Tim Waugh 2007-07-31 10:54:35 EDT
[tim@cyberelk ~]$ rpm -q bash
bash-3.1-16.1
[tim@cyberelk ~]$ ulimit -v 1
[tim@cyberelk ~]$ ls
Killed
Comment 3 Bill C. Riemers 2007-07-31 12:08:31 EDT
Hmmm.  You are right, ulimit -v works.  It is only when you try to make it a
hard limit it fails to work:

(ulimit -H -v 1;ls)

In general, it looks like the it is the relationship between hard and soft
limits that is broken.  For example, in theory the following should be legal
because 1 is less than 20000:

(ulimit -H -v 20000; ulimit -S -v 1 ; ls )

But instead the following error is returned:

bash: ulimit: virtual memory: cannot modify limit: Invalid argument

I am lowering the priority, since in most cases the -H flag is not necessary.

Bill

Comment 4 Tim Waugh 2007-07-31 12:27:23 EDT
My understanding is that 'ulimit -H -v 20000' is expected to fail when the soft
limit remains at 'unlimited'.  Move the soft limit first (-S), then the hard
limit (-H); or else move both at once (just -v on its own).
Comment 5 Bill C. Riemers 2007-07-31 12:38:23 EDT
From a usability standpoint, it doesn't make sense to work that way.  But, that
is the way it is designed...


Note You need to log in before you can comment on or make changes to this bug.